Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC Post Code Daemon" |
| 2 | DESCRIPTION = "Phosphor OpenBMC Post Code Daemon" |
Patrick Venture | a9ac4e5 | 2018-09-28 19:21:26 -0700 | [diff] [blame] | 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-host-postd" |
Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 4 | PR = "r1" |
Patrick Venture | a9ac4e5 | 2018-09-28 19:21:26 -0700 | [diff] [blame] | 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 8 | |
| 9 | inherit autotools pkgconfig |
Patrick Venture | c787422 | 2018-10-23 11:57:36 -0700 | [diff] [blame] | 10 | inherit systemd |
Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 11 | |
Benjamin Fair | a41f246 | 2020-04-07 11:48:40 -0700 | [diff] [blame] | 12 | PACKAGECONFIG ?= "" |
| 13 | PACKAGECONFIG[7seg] = "--enable-7seg,--disable-7seg,,udev" |
| 14 | |
Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 15 | DEPENDS += "autoconf-archive-native" |
| 16 | DEPENDS += "sdbusplus" |
Kun Yi | cf49244 | 2018-09-12 11:01:33 -0700 | [diff] [blame] | 17 | DEPENDS += "sdeventplus" |
Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 18 | DEPENDS += "phosphor-dbus-interfaces" |
| 19 | DEPENDS += "systemd" |
| 20 | |
Patrick Venture | a9ac4e5 | 2018-09-28 19:21:26 -0700 | [diff] [blame] | 21 | S = "${WORKDIR}/git" |
| 22 | SRC_URI = "git://github.com/openbmc/phosphor-host-postd" |
Andrew Geissler | 8bc56eb | 2020-04-20 03:41:06 +0000 | [diff] [blame] | 23 | SRCREV = "66efa632e25854ed5fba0166fe5c3bdd6761f20b" |
Patrick Venture | a9ac4e5 | 2018-09-28 19:21:26 -0700 | [diff] [blame] | 24 | |
Benjamin Fair | 8c605cf | 2018-06-29 13:00:14 -0700 | [diff] [blame] | 25 | SNOOP_DEVICE ?= "aspeed-lpc-snoop0" |
| 26 | POST_CODE_BYTES ?= "1" |
| 27 | |
| 28 | SERVICE_FILE = "lpcsnoop.service" |
Patrick Venture | c787422 | 2018-10-23 11:57:36 -0700 | [diff] [blame] | 29 | SYSTEMD_PACKAGES = "${PN}" |
Benjamin Fair | 8c605cf | 2018-06-29 13:00:14 -0700 | [diff] [blame] | 30 | SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}" |
Patrick Venture | c787422 | 2018-10-23 11:57:36 -0700 | [diff] [blame] | 31 | |
| 32 | EXTRA_OECONF = " \ |
| 33 | SNOOP_DEVICE="${SNOOP_DEVICE}" \ |
| 34 | POST_CODE_BYTES="${POST_CODE_BYTES}" \ |
Patrick Venture | d607cfb | 2019-04-04 12:15:22 -0700 | [diff] [blame] | 35 | SYSTEMD_TARGET="multi-user.target" \ |
Patrick Venture | c787422 | 2018-10-23 11:57:36 -0700 | [diff] [blame] | 36 | " |
Benjamin Fair | a41f246 | 2020-04-07 11:48:40 -0700 | [diff] [blame] | 37 | |
| 38 | POSTCODE_SEVENSEG_DEVICE ?= "seven_seg_disp_val" |
| 39 | SERVICE_FILE_7SEG = " \ |
| 40 | postcode-7seg@.service \ |
| 41 | postcode-7seg@${POSTCODE_SEVENSEG_DEVICE}.service \ |
| 42 | " |
| 43 | SYSTEMD_SERVICE_${PN} += "${@bb.utils.contains('PACKAGECONFIG', '7seg', '${SERVICE_FILE_7SEG}', '', d)}" |