Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML" |
| 3 | PR = "r1" |
| 4 | |
| 5 | S = "${WORKDIR}/git" |
| 6 | |
| 7 | inherit autotools pkgconfig |
| 8 | inherit obmc-phosphor-license |
| 9 | inherit pythonnative |
| 10 | |
| 11 | DEPENDS += "autoconf-archive-native" |
Brad Bishop | 5f7b171 | 2017-02-02 20:49:22 -0500 | [diff] [blame] | 12 | DEPENDS += "sdbus++-native" |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 13 | |
Brad Bishop | 5f7b171 | 2017-02-02 20:49:22 -0500 | [diff] [blame] | 14 | PACKAGE_BEFORE_PN = "${PN}-yaml" |
| 15 | |
| 16 | FILES_${PN}-yaml = "${datadir}/${PN}/yaml" |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 17 | |
| 18 | SRC_URI += "git://github.com/openbmc/phosphor-dbus-interfaces" |
Patrick Williams | 46079ba | 2017-02-23 15:50:04 -0600 | [diff] [blame] | 19 | SRCREV = "b0360faedbf1ff91989129af332f22572158c2cf" |
Brad Bishop | 5f7b171 | 2017-02-02 20:49:22 -0500 | [diff] [blame] | 20 | |
| 21 | DEPENDS_remove_class-native = "sdbus++-native" |
| 22 | DEPENDS_remove_class-nativesdk = "sdbus++-native" |
| 23 | |
| 24 | PACKAGECONFIG ??= "libphosphor_dbus" |
Brad Bishop | 82f51bf | 2017-02-13 14:28:28 -0500 | [diff] [blame] | 25 | PACKAGECONFIG[libphosphor_dbus] = " \ |
| 26 | --enable-libphosphor_dbus, \ |
| 27 | --disable-libphosphor_dbus, \ |
| 28 | systemd sdbusplus, \ |
| 29 | libsystemd sdbusplus \ |
| 30 | " |
Brad Bishop | 5f7b171 | 2017-02-02 20:49:22 -0500 | [diff] [blame] | 31 | |
| 32 | PACKAGECONFIG_remove_class-native = "libphosphor_dbus" |
| 33 | PACKAGECONFIG_remove_class-nativesdk = "libphosphor_dbus" |
| 34 | |
| 35 | BBCLASSEXTEND += "native nativesdk" |