blob: 0a1c8bd1d3706f1acee71a5fa7474c5cd65e7fbc [file] [log] [blame]
Deepak Kodihalli5b183e02017-02-20 04:55:20 -06001SUMMARY = "FRU properties config for ipmi-fru-parser"
2PR = "r1"
3
4inherit native
5inherit obmc-phosphor-license
6inherit phosphor-ipmi-fru
Matt Spinler3f6fcbe2017-12-14 13:31:55 -06007inherit mrw-xml
Deepak Kodihalli5b183e02017-02-20 04:55:20 -06008
9SRC_URI += "file://config.yaml"
10
11DEPENDS += " \
12 mrw-native \
13 mrw-perl-tools-native \
14 "
15
16PROVIDES += "virtual/phosphor-ipmi-fru-properties"
17
18S = "${WORKDIR}"
19
20do_install() {
21 DEST=${D}${properties_datadir}
22 install -d ${DEST}
23
24 ${bindir}/perl-native/perl \
25 ${bindir}/gen_fru_properties.pl \
Matt Spinler3f6fcbe2017-12-14 13:31:55 -060026 -m ${mrw_datadir}/${MRW_XML} \
Deepak Kodihalli5b183e02017-02-20 04:55:20 -060027 -c config.yaml \
Ratan Guptadccf5ad2017-03-30 14:32:02 +053028 -o ${DEST}/extra-properties.yaml
Deepak Kodihalli5b183e02017-02-20 04:55:20 -060029}