blob: 2d5b5b8708e13846335dfe6890acde617f3011d6 [file] [log] [blame]
Matthew Barth91460422017-02-24 13:14:43 -06001SUMMARY = "Phosphor Fan Presence"
2DESCRIPTION = "Phosphor fan presence provides a set of fan presence \
3daemons to monitor fan presence changes by different methods of \
4presence detection."
Matthew Barth91460422017-02-24 13:14:43 -06005PR = "r1"
Matt Spinlerc943de32017-03-21 15:02:13 -05006
7require ${PN}.inc
Matthew Barth91460422017-02-24 13:14:43 -06008
9inherit autotools pkgconfig pythonnative
10inherit obmc-phosphor-systemd
Matt Spinlerc943de32017-03-21 15:02:13 -050011inherit phosphor-fan-presence
Matthew Barth91460422017-02-24 13:14:43 -060012
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "python-pyyaml-native"
Matt Spinlerc943de32017-03-21 15:02:13 -050015DEPENDS += "python-mako-native"
Matthew Barth91460422017-02-24 13:14:43 -060016DEPENDS += "sdbusplus"
17DEPENDS += "phosphor-logging"
Matt Spinlerc943de32017-03-21 15:02:13 -050018DEPENDS += "virtual/phosphor-fan-presence-config"
Matthew Barth91460422017-02-24 13:14:43 -060019RDEPENDS_${PN} += "sdbusplus"
20
21FAN_PRESENCE_PACKAGES = " \
22 ${PN}-tach \
23"
24PACKAGES_remove = "${PN}"
25PACKAGES += "${FAN_PRESENCE_PACKAGES}"
26SYSTEMD_PACKAGES = "${FAN_PRESENCE_PACKAGES}"
27RDEPENDS_${PN}-dev = "${FAN_PRESENCE_PACKAGES}"
28
29# Needed to install into the obmc-chassis-start target
30TMPL = "phosphor-fan-presence-tach@.service"
31INSTFMT = "phosphor-fan-presence-tach@{0}.service"
32TGTFMT = "obmc-chassis-start@{0}.target"
33FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
34
35FILES_${PN}-tach = "${sbindir}/phosphor-fan-presence-tach"
36SYSTEMD_SERVICE_${PN}-tach += "${TMPL}"
37SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
38
Matthew Barth91460422017-02-24 13:14:43 -060039S = "${WORKDIR}/git"
Matt Spinlerc943de32017-03-21 15:02:13 -050040
41EXTRA_OECONF = \
42 "FAN_DETECT_YAML_FILE=${STAGING_DIR_NATIVE}${presence_datadir}/config.yaml"