blob: 5cbbe408d4fbad461befd83b54a83b425544c9d0 [file] [log] [blame]
Patrick Venture028d2402018-03-09 15:37:45 -08001SUMMARY = "Phosphor PID Fan Control"
2DESCRIPTION = "Fan Control"
Patrick Venturec311dec2018-09-29 09:19:22 -07003HOMEPAGE = "github.com/openbmc/phosphor-pid-control"
Patrick Venture028d2402018-03-09 15:37:45 -08004PR = "r1"
Patrick Venturec311dec2018-09-29 09:19:22 -07005PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture028d2402018-03-09 15:37:45 -08008
James Feistae3f0852018-11-20 11:29:16 -08009inherit flto-automake pkgconfig
Patrick Venture028d2402018-03-09 15:37:45 -080010inherit pythonnative
11
12inherit phosphor-pid-control
13inherit obmc-phosphor-ipmiprovider-symlink
14
Patrick Venturec311dec2018-09-29 09:19:22 -070015S = "${WORKDIR}/git"
16SRC_URI = "git://github.com/openbmc/phosphor-pid-control"
Andrew Geisslere5ad9ec2019-03-11 16:41:52 +000017SRCREV = "6d31049a4eb38f7b86874e9286c771ae0dd5f14d"
Patrick Venturec311dec2018-09-29 09:19:22 -070018
Patrick Venture028d2402018-03-09 15:37:45 -080019# Each platform will need a service file that starts
20# at an appropriate time per system. For instance, if
21# your system relies on passive dbus for fans or other
22# sensors then it may be prudent to wait for all of them.
23
24DEPENDS += "autoconf-archive-native"
25DEPENDS += "python-pyyaml-native"
26DEPENDS += "python-mako-native"
27DEPENDS += "sdbusplus"
28DEPENDS += "phosphor-logging"
29DEPENDS += "libevdev"
Patrick Venture9b40f492019-02-12 08:59:31 -080030DEPENDS += "nlohmann-json"
Patrick Ventured0742562019-03-11 08:45:12 -070031DEPENDS += "cli11"
Patrick Venture028d2402018-03-09 15:37:45 -080032
Patrick Venture028d2402018-03-09 15:37:45 -080033# We depend on this to be built first so we can build our providers.
34DEPENDS += "phosphor-ipmi-host"
35
36RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
37
38FILES_${PN} = "${sbindir}/swampd ${sbindir}/setsensor"
39
Patrick Venture13a1e6b2018-07-27 07:27:01 -070040# The following installs the OEM IPMI handler for the fan controls.
41FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
42FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
43FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
44FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Patrick Venture028d2402018-03-09 15:37:45 -080045
Patrick Venture13a1e6b2018-07-27 07:27:01 -070046HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so"