Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 1 | SUMMARY = "C++ bindings for systemd dbus APIs" |
| 2 | DESCRIPTION = "C++ bindings for systemd dbus APIs." |
| 3 | HOMEPAGE = "http://github.com/openbmc/sdbusplus" |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 7 | |
| 8 | inherit autotools pkgconfig |
Patrick Williams | 5818530 | 2016-11-22 07:01:14 -0600 | [diff] [blame] | 9 | inherit obmc-phosphor-python-autotools |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 10 | |
| 11 | DEPENDS += "autoconf-archive-native" |
Brad Bishop | 29dc870 | 2017-01-12 14:06:43 -0500 | [diff] [blame] | 12 | RDEPENDS_sdbus++ += " \ |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 13 | python-inflection \ |
| 14 | python-mako \ |
| 15 | python-pyyaml \ |
| 16 | " |
| 17 | |
Brad Bishop | 32f0a9a | 2017-01-18 13:59:33 -0500 | [diff] [blame] | 18 | # sdbus++ has a handful of runtime dependencies on other python packages. |
| 19 | # Bitbake doesn't do anything with RDEPENDS in native context because |
| 20 | # native context doesn't have packages. |
| 21 | # |
| 22 | # While technically sdbus++ doesn't require its runtime dependencies to be |
| 23 | # installed to build, work around the above native context behavior |
| 24 | # by adding a build dependency so that clients don't have to DEPEND |
| 25 | # on sdbus++ runtime dependencies manually. |
| 26 | |
| 27 | DEPENDS_append_class-native = " \ |
| 28 | python-inflection-native \ |
| 29 | python-mako-native \ |
| 30 | python-pyyaml-native \ |
| 31 | " |
| 32 | |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 33 | SRC_URI += "git://github.com/openbmc/sdbusplus" |
Patrick Williams | d1d94d9 | 2017-04-18 16:50:03 -0500 | [diff] [blame] | 34 | SRCREV = "ba6f50cde819e1b662ec1516c873d76ea572d90f" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 35 | |
Adriana Kobylak | 178d6b5 | 2017-02-12 17:40:26 -0600 | [diff] [blame] | 36 | PACKAGECONFIG ??= "libsdbusplus transaction" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 37 | PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd" |
Adriana Kobylak | 178d6b5 | 2017-02-12 17:40:26 -0600 | [diff] [blame] | 38 | PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 39 | |
| 40 | S = "${WORKDIR}/git" |
| 41 | |
Patrick Williams | 2979202 | 2016-11-22 11:05:11 -0600 | [diff] [blame] | 42 | PROVIDES_prepend = "sdbus++ " |
| 43 | PACKAGES_prepend = "sdbus++ " |
| 44 | FILES_sdbus++_append = " ${bindir}/sdbus++" |
| 45 | PYTHON_AUTOTOOLS_PACKAGE = "sdbus++" |
| 46 | |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 47 | PACKAGECONFIG_remove_class-native = "libsdbusplus" |
| 48 | PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus" |
| 49 | |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 50 | BBCLASSEXTEND += "native nativesdk" |