Matt Spinler | 2332ef8 | 2016-08-25 13:04:09 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor machine readable workbook patching script" |
| 2 | DESCRIPTION = "Retrieve the script that can patch the MRW XML" |
| 3 | PR = "r1" |
Patrick Venture | ef14250 | 2018-10-30 11:44:04 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Matt Spinler | 2332ef8 | 2016-08-25 13:04:09 -0500 | [diff] [blame] | 5 | |
| 6 | S = "${WORKDIR}/git" |
| 7 | |
| 8 | inherit obmc-phosphor-license |
| 9 | inherit native |
Matt Spinler | de33cae | 2016-09-15 10:39:43 -0500 | [diff] [blame] | 10 | inherit mrw-rev |
Matt Spinler | 2332ef8 | 2016-08-25 13:04:09 -0500 | [diff] [blame] | 11 | |
| 12 | DEPENDS += "python-native python-lxml-native" |
| 13 | |
Patrick Williams | 4f02a45 | 2016-10-31 15:46:40 -0500 | [diff] [blame] | 14 | SRC_URI += "${MRW_TOOLS_SRC_URI}" |
| 15 | SRCREV = "${MRW_TOOLS_SRCREV}" |
Matt Spinler | 2332ef8 | 2016-08-25 13:04:09 -0500 | [diff] [blame] | 16 | |
| 17 | do_install() { |
Matt Spinler | 471b885 | 2016-09-20 13:32:44 -0500 | [diff] [blame] | 18 | install -d ${D}${bindir}/obmc-mrw |
| 19 | install -m 0755 patchxml.py ${D}${bindir}/obmc-mrw |
Matt Spinler | 2332ef8 | 2016-08-25 13:04:09 -0500 | [diff] [blame] | 20 | } |