Brad Bishop | b0c3b27 | 2017-01-11 11:12:32 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenBMC hwmon poller" |
| 2 | DESCRIPTION = "OpenBMC hwmon poller." |
| 3 | PR = "r1" |
| 4 | |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc" |
| 7 | |
Brad Bishop | 030da25 | 2017-01-11 15:30:07 -0500 | [diff] [blame] | 8 | inherit autotools pkgconfig obmc-phosphor-systemd |
| 9 | |
Brad Bishop | 1d34ddd | 2017-08-01 21:33:30 -0400 | [diff] [blame] | 10 | PACKAGE_BEFORE_PN = "max31785-msl" |
| 11 | SYSTEMD_PACKAGES = "${PN} max31785-msl" |
| 12 | |
Brad Bishop | 030da25 | 2017-01-11 15:30:07 -0500 | [diff] [blame] | 13 | SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service" |
Brad Bishop | 1d34ddd | 2017-08-01 21:33:30 -0400 | [diff] [blame] | 14 | SYSTEMD_SERVICE_max31785-msl = "phosphor-max31785-msl@.service" |
Brad Bishop | b0c3b27 | 2017-01-11 11:12:32 -0500 | [diff] [blame] | 15 | |
| 16 | DEPENDS += "autoconf-archive-native" |
Brad Bishop | f4393bf | 2017-02-20 14:36:31 -0500 | [diff] [blame] | 17 | DEPENDS += " \ |
| 18 | sdbusplus \ |
| 19 | phosphor-dbus-interfaces \ |
| 20 | phosphor-logging \ |
Patrick Venture | 03c5391 | 2018-09-14 09:54:18 -0700 | [diff] [blame] | 21 | gpioplus \ |
Brad Bishop | f4393bf | 2017-02-20 14:36:31 -0500 | [diff] [blame] | 22 | " |
| 23 | |
Brad Bishop | b0c3b27 | 2017-01-11 11:12:32 -0500 | [diff] [blame] | 24 | |
| 25 | RDEPENDS_${PN} += "\ |
Brad Bishop | f4393bf | 2017-02-20 14:36:31 -0500 | [diff] [blame] | 26 | sdbusplus \ |
| 27 | phosphor-dbus-interfaces \ |
| 28 | phosphor-logging \ |
Patrick Venture | 03c5391 | 2018-09-14 09:54:18 -0700 | [diff] [blame] | 29 | gpioplus \ |
Joel Stanley | 7b29e20 | 2017-09-05 17:44:33 +1000 | [diff] [blame] | 30 | bash \ |
Brad Bishop | b0c3b27 | 2017-01-11 11:12:32 -0500 | [diff] [blame] | 31 | " |
| 32 | |
Brad Bishop | fe7871c | 2017-02-22 20:50:13 -0500 | [diff] [blame] | 33 | RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}" |
| 34 | |
Brad Bishop | 1d34ddd | 2017-08-01 21:33:30 -0400 | [diff] [blame] | 35 | FILES_max31785-msl = "${bindir}/max31785-msl" |
| 36 | RDEPENDS_max31785-msl = "${VIRTUAL-RUNTIME_base-utils} i2c-tools" |
| 37 | |
Brad Bishop | b0c3b27 | 2017-01-11 11:12:32 -0500 | [diff] [blame] | 38 | SRC_URI += "git://github.com/openbmc/phosphor-hwmon" |
Brad Bishop | 030da25 | 2017-01-11 15:30:07 -0500 | [diff] [blame] | 39 | SRC_URI += "file://70-hwmon.rules" |
Brandon Wyman | 675ce0b | 2017-06-21 16:32:56 -0500 | [diff] [blame] | 40 | SRC_URI += "file://70-iio.rules" |
Joel Stanley | 7b29e20 | 2017-09-05 17:44:33 +1000 | [diff] [blame] | 41 | SRC_URI += "file://start_hwmon.sh" |
Brad Bishop | b0c3b27 | 2017-01-11 11:12:32 -0500 | [diff] [blame] | 42 | |
Andrew Geissler | 5de553b | 2018-09-12 14:20:21 +0000 | [diff] [blame] | 43 | SRCREV = "af6227a3eb3fc918425d7588e001a75bd348232d" |
Brad Bishop | b0c3b27 | 2017-01-11 11:12:32 -0500 | [diff] [blame] | 44 | |
| 45 | S = "${WORKDIR}/git" |
Brad Bishop | 030da25 | 2017-01-11 15:30:07 -0500 | [diff] [blame] | 46 | |
| 47 | do_install_append() { |
| 48 | |
Brad Bishop | f5812fd | 2017-01-26 09:12:57 -0500 | [diff] [blame] | 49 | install -d ${D}/${base_libdir}/udev/rules.d/ |
| 50 | install ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/ |
Brandon Wyman | 675ce0b | 2017-06-21 16:32:56 -0500 | [diff] [blame] | 51 | install ${WORKDIR}/70-iio.rules ${D}/${base_libdir}/udev/rules.d/ |
Joel Stanley | 7b29e20 | 2017-09-05 17:44:33 +1000 | [diff] [blame] | 52 | |
| 53 | install -d ${D}${bindir} |
| 54 | install -m 0755 ${WORKDIR}/start_hwmon.sh ${D}${bindir} |
Brad Bishop | 030da25 | 2017-01-11 15:30:07 -0500 | [diff] [blame] | 55 | } |