blob: e15bbd956664c62e8cd39fef18fba6457a9427dc [file] [log] [blame]
Patrick Venture76428942017-05-09 10:04:13 -07001SUMMARY = "Quanta Q71l board wiring"
2DESCRIPTION = "Board wiring information for the Quanta Q71l system."
3PR = "r1"
Patrick Venturea20f4c02018-11-06 09:40:40 -08004LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${QUANTABASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Patrick Venture76428942017-05-09 10:04:13 -07006
7inherit allarch
8inherit setuptools
9inherit pythonnative
Patrick Venture76428942017-05-09 10:04:13 -070010
11PROVIDES += "virtual/obmc-inventory-data"
12RPROVIDES_${PN} += "virtual-obmc-inventory-data"
13
14DEPENDS += "python"
15
16S = "${WORKDIR}"
17SRC_URI += "file://Quanta-q71l.py"
18
19# the following is unnecessary.
20python() {
21 machine = d.getVar('MACHINE', True).capitalize() + '.py'
22 d.setVar('_config_in_skeleton', machine)
23}
24
25do_make_setup() {
26 cp ${S}/${_config_in_skeleton} \
27 ${S}/obmc_system_config.py
28 cat <<EOF > ${S}/setup.py
29from distutils.core import setup
30
31setup(name='${BPN}',
32 version='${PR}',
33 py_modules=['obmc_system_config'],
34 )
35EOF
36}
37
38addtask make_setup after do_patch before do_configure