Patrick Venture | 7642894 | 2017-05-09 10:04:13 -0700 | [diff] [blame] | 1 | SUMMARY = "Quanta Q71l board wiring" |
| 2 | DESCRIPTION = "Board wiring information for the Quanta Q71l system." |
| 3 | PR = "r1" |
Patrick Venture | a20f4c0 | 2018-11-06 09:40:40 -0800 | [diff] [blame] | 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${QUANTABASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
Patrick Venture | 7642894 | 2017-05-09 10:04:13 -0700 | [diff] [blame] | 6 | |
| 7 | inherit allarch |
| 8 | inherit setuptools |
| 9 | inherit pythonnative |
Patrick Venture | 7642894 | 2017-05-09 10:04:13 -0700 | [diff] [blame] | 10 | |
| 11 | PROVIDES += "virtual/obmc-inventory-data" |
| 12 | RPROVIDES_${PN} += "virtual-obmc-inventory-data" |
| 13 | |
| 14 | DEPENDS += "python" |
| 15 | |
| 16 | S = "${WORKDIR}" |
| 17 | SRC_URI += "file://Quanta-q71l.py" |
| 18 | |
| 19 | # the following is unnecessary. |
| 20 | python() { |
| 21 | machine = d.getVar('MACHINE', True).capitalize() + '.py' |
| 22 | d.setVar('_config_in_skeleton', machine) |
| 23 | } |
| 24 | |
| 25 | do_make_setup() { |
| 26 | cp ${S}/${_config_in_skeleton} \ |
| 27 | ${S}/obmc_system_config.py |
| 28 | cat <<EOF > ${S}/setup.py |
| 29 | from distutils.core import setup |
| 30 | |
| 31 | setup(name='${BPN}', |
| 32 | version='${PR}', |
| 33 | py_modules=['obmc_system_config'], |
| 34 | ) |
| 35 | EOF |
| 36 | } |
| 37 | |
| 38 | addtask make_setup after do_patch before do_configure |