Patrick Venture | 864fa49 | 2018-11-05 20:48:03 -0800 | [diff] [blame] | 1 | LICENSE = "Apache-2.0" |
| 2 | LIC_FILES_CHKSUM = "file://${QUANTABASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
| 3 | |
Patrick Venture | 44b67f5 | 2018-04-13 13:41:52 -0700 | [diff] [blame] | 4 | inherit native |
Patrick Venture | 44b67f5 | 2018-04-13 13:41:52 -0700 | [diff] [blame] | 5 | |
| 6 | DEPENDS += "virtual/phosphor-ipmi-fru-inventory" |
| 7 | PROVIDES += "virtual/phosphor-ipmi-fru-merge-config" |
| 8 | |
| 9 | # Put the fru_config in the right place with the right name. |
| 10 | # Pull the IPMI FRU YAML config to use it in the IPMI HOST YAML. |
| 11 | do_install_append() { |
| 12 | IPMI_FRU_SRC=${datadir}/phosphor-ipmi-fru/config |
| 13 | IPMI_HOST_DEST=${D}${datadir}/phosphor-ipmi-host/config |
| 14 | install -d ${IPMI_HOST_DEST} |
| 15 | cat ${IPMI_FRU_SRC}/config.yaml > ${IPMI_HOST_DEST}/fru_config.yaml |
| 16 | } |