Patrick Venture | 7642894 | 2017-05-09 10:04:13 -0700 | [diff] [blame] | 1 | SUMMARY = "Quanta Q71l board wiring" |
| 2 | DESCRIPTION = "Board wiring information for the Quanta Q71l system." |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit allarch |
| 6 | inherit setuptools |
| 7 | inherit pythonnative |
| 8 | inherit obmc-phosphor-license |
| 9 | |
| 10 | PROVIDES += "virtual/obmc-inventory-data" |
| 11 | RPROVIDES_${PN} += "virtual-obmc-inventory-data" |
| 12 | |
| 13 | DEPENDS += "python" |
| 14 | |
| 15 | S = "${WORKDIR}" |
| 16 | SRC_URI += "file://Quanta-q71l.py" |
| 17 | |
| 18 | # the following is unnecessary. |
| 19 | python() { |
| 20 | machine = d.getVar('MACHINE', True).capitalize() + '.py' |
| 21 | d.setVar('_config_in_skeleton', machine) |
| 22 | } |
| 23 | |
| 24 | do_make_setup() { |
| 25 | cp ${S}/${_config_in_skeleton} \ |
| 26 | ${S}/obmc_system_config.py |
| 27 | cat <<EOF > ${S}/setup.py |
| 28 | from distutils.core import setup |
| 29 | |
| 30 | setup(name='${BPN}', |
| 31 | version='${PR}', |
| 32 | py_modules=['obmc_system_config'], |
| 33 | ) |
| 34 | EOF |
| 35 | } |
| 36 | |
| 37 | addtask make_setup after do_patch before do_configure |