blob: 104f07fda82428cdb27fb60733a88be6b74e431b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Open Package Manager"
2SUMMARY_libopkg = "Open Package Manager library"
3SECTION = "base"
4HOMEPAGE = "http://code.google.com/p/opkg/"
5BUGTRACKER = "http://code.google.com/p/opkg/issues/list"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0"
9
10DEPENDS = "libarchive"
11
12PE = "1"
13
14SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
15 file://opkg.conf \
16 file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040017 file://run-ptest \
Brad Bishop19323692019-04-05 15:28:33 -040018"
19
Brad Bishop96ff1982019-08-19 13:50:42 -040020SRC_URI[md5sum] = "ba0c21305fc93b26e844981ef100dc85"
21SRC_URI[sha256sum] = "45ac1e037d3877f635d883f8a555e172883a25d3eeb7986c75890fdd31250a43"
Brad Bishop19323692019-04-05 15:28:33 -040022
Brad Bishopc342db32019-05-15 21:57:59 -040023# This needs to be before ptest inherit, otherwise all ptest files end packaged
24# in libopkg package if OPKGLIBDIR == libdir, because default
25# PTEST_PATH ?= "${libdir}/${BPN}/ptest"
26PACKAGES =+ "libopkg"
27
Brad Bishop00e122a2019-10-05 11:10:57 -040028inherit autotools pkgconfig ptest
Brad Bishop19323692019-04-05 15:28:33 -040029
30target_localstatedir := "${localstatedir}"
Brad Bishop96ff1982019-08-19 13:50:42 -040031OPKGLIBDIR ??= "${target_localstatedir}/lib"
Brad Bishop19323692019-04-05 15:28:33 -040032
33PACKAGECONFIG ??= "libsolv"
34
35PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg"
36PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
37PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
38PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
39PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
Brad Bishop19323692019-04-05 15:28:33 -040040PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
41
Brad Bishop00e122a2019-10-05 11:10:57 -040042EXTRA_OECONF += " --disable-pathfinder"
Brad Bishop19323692019-04-05 15:28:33 -040043EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}"
44
Brad Bishop96ff1982019-08-19 13:50:42 -040045# Release tarball has unused binaries on the tests folder, automatically created by automake.
46# For now, delete them to avoid packaging errors (wrong architecture)
47do_unpack_append () {
48 bb.build.exec_func('remove_test_binaries', d)
49}
50
51remove_test_binaries () {
52 rm ${WORKDIR}/opkg-${PV}/tests/libopkg_test*
53}
54
Brad Bishop19323692019-04-05 15:28:33 -040055do_install_append () {
56 install -d ${D}${sysconfdir}/opkg
57 install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
58 echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf
59
60 # We need to create the lock directory
61 install -d ${D}${OPKGLIBDIR}/opkg
62}
63
Brad Bishop96ff1982019-08-19 13:50:42 -040064do_install_ptest () {
65 sed -i -e '/@echo $^/d' ${D}${PTEST_PATH}/tests/Makefile
66 sed -i -e '/@PYTHONPATH=. $(PYTHON) $^/a\\t@if [ "$$?" != "0" ];then echo "FAIL:"$^;else echo "PASS:"$^;fi' ${D}${PTEST_PATH}/tests/Makefile
67}
68
Brad Bishop19323692019-04-05 15:28:33 -040069RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive"
70RDEPENDS_${PN}_class-native = ""
71RDEPENDS_${PN}_class-nativesdk = ""
Brad Bishopc342db32019-05-15 21:57:59 -040072RDEPENDS_${PN}-ptest += "make binutils python3-core python3-compression"
Brad Bishop19323692019-04-05 15:28:33 -040073RREPLACES_${PN} = "opkg-nogpg opkg-collateral"
74RCONFLICTS_${PN} = "opkg-collateral"
75RPROVIDES_${PN} = "opkg-collateral"
76
Brad Bishop19323692019-04-05 15:28:33 -040077FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/"
78
79BBCLASSEXTEND = "native nativesdk"
80
81CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"