blob: 489733c767663c4a3ac536920a560c1e93c274d2 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Python library for CSON (schema-compressed JSON)"
5HOMEPAGE = "https://github.com/gt3389b/python-cson/"
6LICENSE = "MIT"
7SECTION = "devel/python"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=7709d2635e63ab96973055a23c2a4cac"
9
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060010PV = "1.0.9+1.0.10"
11SRCREV = "69090778bccc5ed124342ba288597fbb2bfa9f39"
12SRC_URI = "git://github.com/gt3389b/python-cson.git;branch=master;protocol=https \
13 file://0001-setup.py-Do-not-poke-at-git-describe-to-find-version.patch"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15S = "${WORKDIR}/git"
16
Patrick Williamsb542dec2023-06-09 01:26:37 -050017RDEPENDS:${PN} = "python3-json"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018
19inherit setuptools3
20
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060021do_configure:prepend() {
22 echo "__version__=${PV}" > ${S}/version.py
23}
24
Andrew Geissler82c905d2020-04-13 13:39:40 -050025BBCLASSEXTEND = "native"
26