blob: b28bfe72b739a0475ef9309ffc481d91fda80608 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A high-performance memory object caching system"
2DESCRIPTION = "\
3 memcached optimizes specific high-load serving applications that are designed \
4 to take advantage of its versatile no-locking memory access system. Clients \
5 are available in several different programming languages, to suit the needs \
6 of the specific application. Traditionally this has been used in mod_perl \
7 apps to avoid storing large chunks of data in Apache memory, and to share \
8 this burden across several machines."
9SECTION = "web"
10HOMEPAGE = "http://memcached.org/"
11LICENSE = "BSD-3-Clause"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=7e5ded7363d335e1bb18013ca08046ff"
14
15inherit autotools
16
17DEPENDS += "libevent"
Patrick Williams213cb262021-08-07 19:21:33 -050018RDEPENDS:${PN} += "perl perl-module-posix perl-module-autoloader \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019 perl-module-tie-hash bash \
20 "
21
22SRC_URI = "http://www.memcached.org/files/${BP}.tar.gz \
23 file://memcached-add-hugetlbfs-check.patch \
24 "
Patrick Williams03907ee2022-05-01 06:28:52 -050025SRC_URI[sha256sum] = "8d7abe3d649378edbba16f42ef1d66ca3f2ac075f2eb97145ce164388e6ed515"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026
27# set the same COMPATIBLE_HOST as libhugetlbfs
Andrew Geissler82c905d2020-04-13 13:39:40 -050028COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64|aarch64|arm).*-linux*"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029
30python __anonymous () {
31 endianness = d.getVar('SITEINFO_ENDIANNESS')
32 if endianness == 'le':
33 d.appendVar('EXTRA_OECONF', " ac_cv_c_endian=little")
34 else:
35 d.appendVar('EXTRA_OECONF', " ac_cv_c_endian=big")
36}
37
38PACKAGECONFIG ??= ""
39PACKAGECONFIG[hugetlbfs] = "--enable-hugetlbfs, --disable-hugetlbfs, libhugetlbfs"
40
41inherit update-rc.d
42
43INITSCRIPT_NAME = "memcached"
44INITSCRIPT_PARAMS = "defaults"
45
Patrick Williams213cb262021-08-07 19:21:33 -050046do_install:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080047 install -D -m 755 ${S}/scripts/memcached-init ${D}${sysconfdir}/init.d/memcached
48 mkdir -p ${D}/usr/share/memcached/scripts
49 install -m 755 ${S}/scripts/memcached-tool ${D}/usr/share/memcached/scripts
50 install -m 755 ${S}/scripts/start-memcached ${D}/usr/share/memcached/scripts
51}