blob: 3be8c76b54a944b58816ba36fd452ade71f6b0cb [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Linux Kernel Crypto API User Space Interface Library"
2HOMEPAGE = "http://www.chronox.de/libkcapi.html"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "BSD-3-Clause | GPL-2.0-only"
Patrick Williams03907ee2022-05-01 06:28:52 -05004LIC_FILES_CHKSUM = "file://COPYING;md5=a2562899bc38f1735868f0bf0c1dd1a5"
Andrew Geissler595f6302022-01-24 19:11:47 +00005
6S = "${WORKDIR}/git"
Patrick Williams03907ee2022-05-01 06:28:52 -05007SRCREV = "1429ab42d48123cc8f73b96c69a87fb9c6d8a7c9"
Andrew Geissler595f6302022-01-24 19:11:47 +00008SRC_URI = "git://github.com/smuellerDD/libkcapi.git;branch=master;protocol=https \
Andrew Geissler595f6302022-01-24 19:11:47 +00009 "
10
11inherit autotools
12
13PACKAGECONFIG ??= ""
14PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash"
15PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,,"
16PACKAGECONFIG[hasher_only] = "--enable-kcapi-hasher --disable-lib-kdf --disable-lib-sym --disable-lib-aead --disable-lib-rng,,,"
17
18do_install:append() {
19 # bindir contains testapp and apps. However it is always created, even
20 # when no binaries are installed (empty bin_PROGRAMS in Makefile.am),
21 rmdir --ignore-fail-on-non-empty ${D}${bindir}
22
23 # Remove the generated binary checksum files
24 rm -f ${D}${bindir}/.*.hmac
25 rm -f ${D}${libdir}/.*.hmac
26}
27
28CPPFLAGS:append:libc-musl:toolchain-clang = " -Wno-error=sign-compare"
Patrick Williams03907ee2022-05-01 06:28:52 -050029CPPFLAGS:remove:libc-musl:toolchain-clang = "-Wno-error=sign-conversion"
30CPPFLAGS:append:libc-musl = " -Wno-error=sign-conversion"
Andrew Geissler595f6302022-01-24 19:11:47 +000031
32BBCLASSEXTEND = "native"