blob: 29e7a267d2a913ca2984f70308d93ffcf558fb71 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "GUI tool for storage configuration using blivet library"
2HOMEPAGE = "https://github.com/rhinstaller/blivet-gui"
3LICENSE = "GPL-2.0-or-later"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8S = "${WORKDIR}/git"
9B = "${S}"
10
11SRCREV = "42512ee48494cee71febf04078d9774f0146a085"
12SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=master;protocol=https \
13 file://0001-Use-setuptools-instead-of-distutils-in-setup.py.patch \
Patrick Williams03907ee2022-05-01 06:28:52 -050014 file://0002-Use-symbolic-list-add-and-edit-icons.patch \
15 "
Andrew Geissler9aee5002022-03-30 16:27:02 +000016
17inherit features_check
18REQUIRED_DISTRO_FEATURES = "x11 systemd"
19
20inherit setuptools3_legacy python3native
21
22PIP_INSTALL_PACKAGE = "blivet_gui"
23
24RDEPENDS:${PN} = "python3-pygobject python3 \
25 python3-blivet gtk+3 \
26 python3-pid libreport \
27"
28
29FILES:${PN} += " \
30 ${datadir}/* \
31 "