blob: e473b9cd55690072b370b97d91366388c64a8a4f [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Utility for modifying GPT disk partitioning"
2DESCRIPTION = "GPT fdisk is a disk partitioning tool loosely modeled on Linux fdisk, but used for modifying GUID Partition Table (GPT) disks. The related FixParts utility fixes some common problems on Master Boot Record (MBR) disks."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003HOMEPAGE = "https://sourceforge.net/projects/gptfdisk/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "GPL-2.0-only"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
7
8DEPENDS = "util-linux"
9
Andrew Geissler4b740dc2020-05-05 08:54:39 -050010SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BP}.tar.gz \
11 file://0001-gptcurses-correctly-include-curses.h.patch \
12 "
Patrick Williams03907ee2022-05-01 06:28:52 -050013SRC_URI[sha256sum] = "dafead2693faeb8e8b97832b23407f6ed5b3219bc1784f482dd855774e2d50c2"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
15UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/gptfdisk/files/gptfdisk/"
16UPSTREAM_CHECK_REGEX = "/gptfdisk/(?P<pver>(\d+[\.\-_]*)+)/"
17
18EXTRA_OEMAKE = "'CC=${CC}' 'CXX=${CXX}' gdisk fixparts ${PACKAGECONFIG_CONFARGS}"
19
20PACKAGECONFIG ??= "ncurses popt"
21PACKAGECONFIG[ncurses] = "cgdisk,,ncurses"
22PACKAGECONFIG[popt] = "sgdisk,,popt"
23
24do_install() {
25 install -d ${D}${sbindir}
26 for f in cgdisk sgdisk; do
27 if [ -x $f ]; then
28 install -m 0755 $f ${D}${sbindir}
29 fi
30 done
31 install -m 0755 gdisk ${D}${sbindir}
32 install -m 0755 fixparts ${D}${sbindir}
33}
34
35BBCLASSEXTEND = "native nativesdk"