blob: 87ab22ed1768921609cbe4e5c2771705377e87a1 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Asynchronous I/O library"
2DESCRIPTION = "Asynchronous input/output library that uses the kernels native interface"
3HOMEPAGE = "http://lse.sourceforge.net/io/aio.html"
4
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "LGPL-2.1-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499"
7
Andrew Geissler595f6302022-01-24 19:11:47 +00008SRC_URI = "git://pagure.io/libaio.git;protocol=https;branch=master \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009 file://00_arches.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010 file://libaio_fix_for_mips_syscalls.patch \
11 file://system-linkage.patch \
12 "
Patrick Williams03907ee2022-05-01 06:28:52 -050013SRCREV = "1b18bfafc6a2f7b9fa2c6be77a95afed8b7be448"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014S = "${WORKDIR}/git"
15
16EXTRA_OEMAKE =+ "prefix=${prefix} includedir=${includedir} libdir=${libdir}"
17
18do_install () {
19 oe_runmake install DESTDIR=${D}
20}
21
Andrew Geissler99467da2019-02-25 18:54:23 -060022BBCLASSEXTEND = "native nativesdk"