blob: 9654488a54089fc14f1ba6ed8936a64f4f8c0bd8 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Linux kernel Development Source"
2DESCRIPTION = "Development source linux kernel. When built, this recipe packages the \
3source of the preferred virtual/kernel provider and makes it available for full kernel \
4development or external module builds"
5
6SECTION = "kernel"
7
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008LICENSE = "GPL-2.0-only"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
10inherit linux-kernel-base
11
12# Whilst not a module, this ensures we don't get multilib extended (which would make no sense)
13inherit module-base
14
15# We need the kernel to be staged (unpacked, patched and configured) before
16# we can grab the source and make the source package. We also need the bits from
17# ${B} not to change while we install, so virtual/kernel must finish do_compile.
18do_install[depends] += "virtual/kernel:do_shared_workdir"
19# Need the source, not just the output of populate_sysroot
20do_install[depends] += "virtual/kernel:do_install"
21
22# There's nothing to do here, except install the source where we can package it
23do_fetch[noexec] = "1"
24do_unpack[noexec] = "1"
25do_patch[noexec] = "1"
26do_configure[noexec] = "1"
27do_compile[noexec] = "1"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028deltask do_populate_sysroot
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030S = "${STAGING_KERNEL_DIR}"
31B = "${STAGING_KERNEL_BUILDDIR}"
32
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033PACKAGE_ARCH = "${MACHINE_ARCH}"
34
Brad Bishop19323692019-04-05 15:28:33 -040035KERNEL_BUILD_ROOT="${nonarch_base_libdir}/modules/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080036
Patrick Williamsc124f4f2015-09-15 14:41:29 -050037do_install() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038 kerneldir=${D}${KERNEL_BUILD_ROOT}${KERNEL_VERSION}
39 install -d $kerneldir
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080041 # create the directory structure
42 rm -f $kerneldir/build
43 rm -f $kerneldir/source
44 mkdir -p $kerneldir/build
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080046 # for compatibility with some older variants of this package, we
47 # create a /usr/src/kernel symlink to /lib/modules/<version>/source
48 mkdir -p ${D}/usr/src
49 (
50 cd ${D}/usr/src
Andrew Geissler595f6302022-01-24 19:11:47 +000051 ln -rs ${D}${KERNEL_BUILD_ROOT}${KERNEL_VERSION}/source kernel
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080052 )
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080054 # for on target purposes, we unify build and source
55 (
56 cd $kerneldir
57 ln -s build source
58 )
Patrick Williamsc124f4f2015-09-15 14:41:29 -050059
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080060 # first copy everything
61 (
62 cd ${S}
63 cp --parents $(find -type f -name "Makefile*" -o -name "Kconfig*") $kerneldir/build
64 cp --parents $(find -type f -name "Build" -o -name "Build.include") $kerneldir/build
65 )
Brad Bishop316dfdd2018-06-25 12:45:53 -040066
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080067 # then drop all but the needed Makefiles/Kconfig files
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080068 rm -rf $kerneldir/build/scripts
69 rm -rf $kerneldir/build/include
70
71 # now copy in parts from the build that we'll need later
72 (
73 cd ${B}
74
Andrew Geissler9aee5002022-03-30 16:27:02 +000075 if [ -s Module.symvers ]; then
76 cp Module.symvers $kerneldir/build
77 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080078 cp System.map* $kerneldir/build
79 if [ -s Module.markers ]; then
80 cp Module.markers $kerneldir/build
81 fi
82
Andrew Geissler82c905d2020-04-13 13:39:40 -050083 cp -a .config $kerneldir/build
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080084
85 # This scripts copy blow up QA, so for now, we require a more
86 # complex 'make scripts' to restore these, versus copying them
87 # here. Left as a reference to indicate that we know the scripts must
88 # be dealt with.
89 # cp -a scripts $kerneldir/build
90
Andrew Geissler6ce62a22020-11-30 19:58:47 -060091 # although module.lds can be regenerated on target via 'make modules_prepare'
92 # there are several places where 'makes scripts prepare' is done, and that won't
93 # regenerate the file. So we copy it onto the target as a migration to using
94 # modules_prepare
95 cp -a --parents scripts/module.lds $kerneldir/build/ 2>/dev/null || :
96
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080097 if [ -d arch/${ARCH}/scripts ]; then
98 cp -a arch/${ARCH}/scripts $kerneldir/build/arch/${ARCH}
99 fi
100 if [ -f arch/${ARCH}/*lds ]; then
101 cp -a arch/${ARCH}/*lds $kerneldir/build/arch/${ARCH}
102 fi
103
104 rm -f $kerneldir/build/scripts/*.o
105 rm -f $kerneldir/build/scripts/*/*.o
106
107 if [ "${ARCH}" = "powerpc" ]; then
108 if [ -e arch/powerpc/lib/crtsavres.S ] ||
109 [ -e arch/powerpc/lib/crtsavres.o ]; then
110 cp -a --parents arch/powerpc/lib/crtsavres.[So] $kerneldir/build/
111 fi
112 fi
113
Andrew Geissler595f6302022-01-24 19:11:47 +0000114 if [ "${ARCH}" = "arm64" -o "${ARCH}" = "riscv" ]; then
Patrick Williams03907ee2022-05-01 06:28:52 -0500115 if [ -e arch/${ARCH}/kernel/vdso/vdso.lds ]; then
116 cp -a --parents arch/${ARCH}/kernel/vdso/vdso.lds $kerneldir/build/
117 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800118 fi
Andrew Geissler5f350902021-07-23 13:09:54 -0400119 if [ "${ARCH}" = "powerpc" ]; then
120 cp -a --parents arch/powerpc/kernel/vdso32/vdso32.lds $kerneldir/build 2>/dev/null || :
121 cp -a --parents arch/powerpc/kernel/vdso64/vdso64.lds $kerneldir/build 2>/dev/null || :
122 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800123
124 cp -a include $kerneldir/build/include
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500125
126 # we don't usually copy generated files, since they can be rebuilt on the target,
127 # but without this file, we get a forced syncconfig run in v5.8+, which prompts and
128 # breaks workflows.
129 cp -a --parents include/generated/autoconf.h $kerneldir/build 2>/dev/null || :
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600130
131 if [ -e $kerneldir/include/generated/.vdso-offsets.h.cmd ]; then
132 rm $kerneldir/include/generated/.vdso-offsets.h.cmd
133 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800134 )
135
136 # now grab the chunks from the source tree that we need
137 (
138 cd ${S}
139
140 cp -a scripts $kerneldir/build
141
142 # if our build dir had objtool, it will also be rebuilt on target, so
143 # we copy what is required for that build
144 if [ -f ${B}/tools/objtool/objtool ]; then
145 # these are a few files associated with objtool, since we'll need to
146 # rebuild it
147 cp -a --parents tools/build/Build.include $kerneldir/build/
148 cp -a --parents tools/build/Build $kerneldir/build/
149 cp -a --parents tools/build/fixdep.c $kerneldir/build/
150 cp -a --parents tools/scripts/utilities.mak $kerneldir/build/
151
152 # extra files, just in case
153 cp -a --parents tools/objtool/* $kerneldir/build/
Andrew Geissler82c905d2020-04-13 13:39:40 -0500154 cp -a --parents tools/lib/* $kerneldir/build/
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800155 cp -a --parents tools/lib/subcmd/* $kerneldir/build/
156
157 cp -a --parents tools/include/* $kerneldir/build/
Andrew Geissler82c905d2020-04-13 13:39:40 -0500158
159 cp -a --parents $(find tools/arch/${ARCH}/ -type f) $kerneldir/build/
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800160 fi
161
162 if [ "${ARCH}" = "arm64" ]; then
163 # arch/arm64/include/asm/xen references arch/arm
164 cp -a --parents arch/arm/include/asm/xen $kerneldir/build/
165 # arch/arm64/include/asm/opcodes.h references arch/arm
166 cp -a --parents arch/arm/include/asm/opcodes.h $kerneldir/build/
167
Brad Bishop79641f22019-09-10 07:20:22 -0400168 cp -a --parents arch/arm64/kernel/vdso/*gettimeofday.* $kerneldir/build/
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800169 cp -a --parents arch/arm64/kernel/vdso/sigreturn.S $kerneldir/build/
170 cp -a --parents arch/arm64/kernel/vdso/note.S $kerneldir/build/
171 cp -a --parents arch/arm64/kernel/vdso/gen_vdso_offsets.sh $kerneldir/build/
172
Andrew Geissler82c905d2020-04-13 13:39:40 -0500173 cp -a --parents arch/arm64/kernel/module.lds $kerneldir/build/ 2>/dev/null || :
Andrew Geissler5f350902021-07-23 13:09:54 -0400174
175 # 5.13+ needs these tools
176 cp -a --parents arch/arm64/tools/gen-cpucaps.awk $kerneldir/build/ 2>/dev/null || :
177 cp -a --parents arch/arm64/tools/cpucaps $kerneldir/build/ 2>/dev/null || :
178
179 if [ -e $kerneldir/build/arch/arm64/tools/gen-cpucaps.awk ]; then
180 sed -i -e "s,#!.*awk.*,#!${USRBINPATH}/env awk," $kerneldir/build/arch/arm64/tools/gen-cpucaps.awk
181 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800182 fi
183
Brad Bishop19323692019-04-05 15:28:33 -0400184 if [ "${ARCH}" = "powerpc" ]; then
185 # 5.0 needs these files, but don't error if they aren't present in the source
186 cp -a --parents arch/${ARCH}/kernel/syscalls/syscall.tbl $kerneldir/build/ 2>/dev/null || :
187 cp -a --parents arch/${ARCH}/kernel/syscalls/syscalltbl.sh $kerneldir/build/ 2>/dev/null || :
188 cp -a --parents arch/${ARCH}/kernel/syscalls/syscallhdr.sh $kerneldir/build/ 2>/dev/null || :
Andrew Geissler5f350902021-07-23 13:09:54 -0400189 cp -a --parents arch/${ARCH}/kernel/vdso32/* $kerneldir/build/ 2>/dev/null || :
190 cp -a --parents arch/${ARCH}/kernel/vdso64/* $kerneldir/build/ 2>/dev/null || :
Brad Bishop19323692019-04-05 15:28:33 -0400191 fi
Andrew Geissler595f6302022-01-24 19:11:47 +0000192 if [ "${ARCH}" = "riscv" ]; then
193 cp -a --parents arch/riscv/kernel/vdso/*gettimeofday.* $kerneldir/build/
194 cp -a --parents arch/riscv/kernel/vdso/note.S $kerneldir/build/
Patrick Williams03907ee2022-05-01 06:28:52 -0500195 if [ -e arch/riscv/kernel/vdso/gen_vdso_offsets.sh ]; then
196 cp -a --parents arch/riscv/kernel/vdso/gen_vdso_offsets.sh $kerneldir/build/
197 fi
Andrew Geissler595f6302022-01-24 19:11:47 +0000198 cp -a --parents arch/riscv/kernel/vdso/* $kerneldir/build/ 2>/dev/null || :
199 fi
Brad Bishop19323692019-04-05 15:28:33 -0400200
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800201 # include the machine specific headers for ARM variants, if available.
202 if [ "${ARCH}" = "arm" ]; then
203 cp -a --parents arch/${ARCH}/mach-*/include $kerneldir/build/
204
205 # include a few files for 'make prepare'
206 cp -a --parents arch/arm/tools/gen-mach-types $kerneldir/build/
207 cp -a --parents arch/arm/tools/mach-types $kerneldir/build/
Brad Bishop19323692019-04-05 15:28:33 -0400208
209 # ARM syscall table tools only exist for kernels v4.10 or later
210 SYSCALL_TOOLS=$(find arch/arm/tools -name "syscall*")
211 if [ -n "$SYSCALL_TOOLS" ] ; then
212 cp -a --parents $SYSCALL_TOOLS $kerneldir/build/
213 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800214
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600215 cp -a --parents arch/arm/kernel/module.lds $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800216 fi
217
218 if [ -d arch/${ARCH}/include ]; then
219 cp -a --parents arch/${ARCH}/include $kerneldir/build/
220 fi
221
222 cp -a include $kerneldir/build
223
Brad Bishop79641f22019-09-10 07:20:22 -0400224 cp -a --parents lib/vdso/* $kerneldir/build/ 2>/dev/null || :
225
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800226 cp -a --parents tools/include/tools/le_byteshift.h $kerneldir/build/
227 cp -a --parents tools/include/tools/be_byteshift.h $kerneldir/build/
228
229 # required for generate missing syscalls prepare phase
Andrew Geissler82c905d2020-04-13 13:39:40 -0500230 cp -a --parents $(find arch/x86 -type f -name "syscall_32.tbl") $kerneldir/build
231 cp -a --parents $(find arch/arm -type f -name "*.tbl") $kerneldir/build 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800232
233 if [ "${ARCH}" = "x86" ]; then
234 # files for 'make prepare' to succeed with kernel-devel
Andrew Geisslerd159c7f2021-09-02 21:05:58 -0500235 cp -a --parents $(find arch/x86 -type f -name "syscall_32.tbl") $kerneldir/build/ 2>/dev/null || :
236 cp -a --parents $(find arch/x86 -type f -name "syscalltbl.sh") $kerneldir/build/ 2>/dev/null || :
237 cp -a --parents $(find arch/x86 -type f -name "syscallhdr.sh") $kerneldir/build/ 2>/dev/null || :
238 cp -a --parents $(find arch/x86 -type f -name "syscall_64.tbl") $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800239 cp -a --parents arch/x86/tools/relocs_32.c $kerneldir/build/
240 cp -a --parents arch/x86/tools/relocs_64.c $kerneldir/build/
241 cp -a --parents arch/x86/tools/relocs.c $kerneldir/build/
242 cp -a --parents arch/x86/tools/relocs_common.c $kerneldir/build/
243 cp -a --parents arch/x86/tools/relocs.h $kerneldir/build/
Andrew Geissler82c905d2020-04-13 13:39:40 -0500244 cp -a --parents arch/x86/tools/gen-insn-attr-x86.awk $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800245 cp -a --parents arch/x86/purgatory/purgatory.c $kerneldir/build/
246
247 # 4.18 + have unified the purgatory files, so we ignore any errors if
248 # these files are not present
249 cp -a --parents arch/x86/purgatory/sha256.h $kerneldir/build/ 2>/dev/null || :
250 cp -a --parents arch/x86/purgatory/sha256.c $kerneldir/build/ 2>/dev/null || :
251
252 cp -a --parents arch/x86/purgatory/stack.S $kerneldir/build/
Brad Bishopc68388fc2019-08-26 01:33:31 -0400253 cp -a --parents arch/x86/purgatory/string.c $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800254 cp -a --parents arch/x86/purgatory/setup-x86_64.S $kerneldir/build/
255 cp -a --parents arch/x86/purgatory/entry64.S $kerneldir/build/
256 cp -a --parents arch/x86/boot/string.h $kerneldir/build/
257 cp -a --parents arch/x86/boot/string.c $kerneldir/build/
Brad Bishopc68388fc2019-08-26 01:33:31 -0400258 cp -a --parents arch/x86/boot/compressed/string.c $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800259 cp -a --parents arch/x86/boot/ctype.h $kerneldir/build/
Andrew Geissler82c905d2020-04-13 13:39:40 -0500260
261 # objtool requires these files
262 cp -a --parents arch/x86/lib/inat.c $kerneldir/build/ 2>/dev/null || :
263 cp -a --parents arch/x86/lib/insn.c $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800264 fi
265
266 if [ "${ARCH}" = "mips" ]; then
267 cp -a --parents arch/mips/Kbuild.platforms $kerneldir/build/
268 cp --parents $(find -type f -name "Platform") $kerneldir/build
269 cp --parents arch/mips/boot/tools/relocs* $kerneldir/build
270 cp -a --parents arch/mips/kernel/asm-offsets.c $kerneldir/build
271 cp -a --parents kernel/time/timeconst.bc $kerneldir/build
272 cp -a --parents kernel/bounds.c $kerneldir/build
273 cp -a --parents Kbuild $kerneldir/build
Brad Bishop19323692019-04-05 15:28:33 -0400274 cp -a --parents arch/mips/kernel/syscalls/*.sh $kerneldir/build 2>/dev/null || :
275 cp -a --parents arch/mips/kernel/syscalls/*.tbl $kerneldir/build 2>/dev/null || :
276 cp -a --parents arch/mips/tools/elf-entry.c $kerneldir/build 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800277 fi
278
279 # required to build scripts/selinux/genheaders/genheaders
280 cp -a --parents security/selinux/include/* $kerneldir/build/
Brad Bishopc342db32019-05-15 21:57:59 -0400281
282 # copy any localversion files
283 cp -a localversion* $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800284 )
285
286 # Make sure the Makefile and version.h have a matching timestamp so that
287 # external modules can be built
288 touch -r $kerneldir/build/Makefile $kerneldir/build/include/generated/uapi/linux/version.h
289
290 # Copy .config to include/config/auto.conf so "make prepare" is unnecessary.
291 cp $kerneldir/build/.config $kerneldir/build/include/config/auto.conf
292
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500293 # make sure these are at least as old as the .config, or rebuilds will trigger
294 touch -r $kerneldir/build/.config $kerneldir/build/include/generated/autoconf.h 2>/dev/null || :
295 touch -r $kerneldir/build/.config $kerneldir/build/include/config/auto.conf* 2>/dev/null || :
296
297 if [ -e "$kerneldir/build/include/config/auto.conf.cmd" ]; then
Andrew Geissler635e0e42020-08-21 15:58:33 -0500298 sed -i 's/ifneq "$(CC)" ".*-linux-.*gcc.*$/ifneq "$(CC)" "gcc"/' "$kerneldir/build/include/config/auto.conf.cmd"
299 sed -i 's/ifneq "$(LD)" ".*-linux-.*ld.bfd.*$/ifneq "$(LD)" "ld"/' "$kerneldir/build/include/config/auto.conf.cmd"
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500300 sed -i 's/ifneq "$(AR)" ".*-linux-.*ar.*$/ifneq "$(AR)" "ar"/' "$kerneldir/build/include/config/auto.conf.cmd"
William A. Kennington IIIac69b482021-06-02 12:28:27 -0700301 sed -i 's/ifneq "$(OBJCOPY)" ".*-linux-.*objcopy.*$/ifneq "$(OBJCOPY)" "objcopy"/' "$kerneldir/build/include/config/auto.conf.cmd"
Andrew Geissler5f350902021-07-23 13:09:54 -0400302 if [ "${ARCH}" = "powerpc" ]; then
303 sed -i 's/ifneq "$(NM)" ".*-linux-.*nm.*$/ifneq "$(NM)" "nm --synthetic"/' "$kerneldir/build/include/config/auto.conf.cmd"
304 else
305 sed -i 's/ifneq "$(NM)" ".*-linux-.*nm.*$/ifneq "$(NM)" "nm"/' "$kerneldir/build/include/config/auto.conf.cmd"
306 fi
Andrew Geisslerc9f78652020-09-18 14:11:35 -0500307 sed -i 's/ifneq "$(HOSTCXX)" ".*$/ifneq "$(HOSTCXX)" "g++"/' "$kerneldir/build/include/config/auto.conf.cmd"
308 sed -i 's/ifneq "$(HOSTCC)" ".*$/ifneq "$(HOSTCC)" "gcc"/' "$kerneldir/build/include/config/auto.conf.cmd"
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500309 sed -i 's/ifneq "$(CC_VERSION_TEXT)".*\(gcc.*\)"/ifneq "$(CC_VERSION_TEXT)" "\1"/' "$kerneldir/build/include/config/auto.conf.cmd"
310 sed -i 's/ifneq "$(srctree)" ".*"/ifneq "$(srctree)" "."/' "$kerneldir/build/include/config/auto.conf.cmd"
Andrew Geissler635e0e42020-08-21 15:58:33 -0500311 # we don't build against the defconfig, so make sure it isn't the trigger for syncconfig
312 sed -i 's/ifneq "$(KBUILD_DEFCONFIG)".*"\(.*\)"/ifneq "\1" "\1"/' "$kerneldir/build/include/config/auto.conf.cmd"
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500313 fi
314
Brad Bishop79641f22019-09-10 07:20:22 -0400315 # make the scripts python3 safe. We won't be running these, and if they are
316 # left as /usr/bin/python rootfs assembly will fail, since we only have python3
317 # in the RDEPENDS (and the python3 package does not include /usr/bin/python)
318 for ss in $(find $kerneldir/build/scripts -type f -name '*'); do
319 sed -i 's,/usr/bin/python2,/usr/bin/env python3,' "$ss"
320 sed -i 's,/usr/bin/env python2,/usr/bin/env python3,' "$ss"
321 sed -i 's,/usr/bin/python,/usr/bin/env python3,' "$ss"
322 done
323
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800324 chown -R root:root ${D}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500325}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800326
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500327# Ensure we don't race against "make scripts" during cpio
328do_install[lockfiles] = "${TMPDIR}/kernel-scripts.lock"
329
Patrick Williams213cb262021-08-07 19:21:33 -0500330FILES:${PN} = "${KERNEL_BUILD_ROOT} ${KERNEL_SRC_PATH}"
331FILES:${PN}-dbg += "${KERNEL_BUILD_ROOT}*/build/scripts/*/.debug/*"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800332
Patrick Williams213cb262021-08-07 19:21:33 -0500333RDEPENDS:${PN} = "bc python3 flex bison ${TCLIBC}-utils"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800334# 4.15+ needs these next two RDEPENDS
Patrick Williams213cb262021-08-07 19:21:33 -0500335RDEPENDS:${PN} += "openssl-dev util-linux"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800336# and x86 needs a bit more for 4.15+
Andrew Geisslerd159c7f2021-09-02 21:05:58 -0500337RDEPENDS:${PN} += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-dev', '', d)}"
Andrew Geissler635e0e42020-08-21 15:58:33 -0500338# 5.8+ needs gcc-plugins libmpc-dev
Patrick Williams213cb262021-08-07 19:21:33 -0500339RDEPENDS:${PN} += "gcc-plugins libmpc-dev"
Andrew Geissler5f350902021-07-23 13:09:54 -0400340# 5.13+ needs awk for arm64
Patrick Williams213cb262021-08-07 19:21:33 -0500341RDEPENDS:${PN}:append:aarch64 = " gawk"
Andrew Geissler5f350902021-07-23 13:09:54 -0400342# 5.13+ needs grep for powerpc
Patrick Williams213cb262021-08-07 19:21:33 -0500343RDEPENDS:${PN}:append:powerpc = " grep"