blob: ddbc49b6cf3c4b061fb3d5867963487858e9a6a2 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "ITS Tool allows you to translate your XML documents with PO files"
2DESCRIPTION = "It extracts messages from XML files and outputs PO template \
3files, then merges translations from MO files to create translated \
4XML files. It determines what to translate and how to chunk it into \
5messages using the W3C Internationalization Tag Set (ITS). "
6HOMEPAGE = "http://itstool.org/"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "GPL-3.0-only"
Patrick Williams03907ee2022-05-01 06:28:52 -05008LIC_FILES_CHKSUM = "\
9 file://COPYING;md5=59c57b95fd7d0e9e238ebbc7ad47c5a5 \
10 file://COPYING.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
11"
Andrew Geisslereff27472021-10-29 15:35:00 -050012
13inherit autotools python3native
14
15DEPENDS = "libxml2-native"
16
17SRC_URI = "http://files.itstool.org/${BPN}/${BPN}-${PV}.tar.bz2 \
18 "
Patrick Williams03907ee2022-05-01 06:28:52 -050019UPSTREAM_CHECK_URI = "https://itstool.org/download.html"
20
Andrew Geisslereff27472021-10-29 15:35:00 -050021SRC_URI:append:class-native = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch"
22SRC_URI:append:class-nativesdk = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch"
23SRC_URI:append:class-target = " file://0002-Don-t-use-build-time-hardcoded-python-binary-path.patch"
24
25SRC_URI[sha256sum] = "6b9a7cd29a12bb95598f5750e8763cee78836a1a207f85b74d8b3275b27e87ca"
26
27BBCLASSEXTEND = "native nativesdk"
28
29RDEPENDS:${PN} += "libxml2-python"