blob: 95add077c6736a051c748d0ee4dd7a733b3edfb2 [file] [log] [blame]
Ed Tanous9936f862022-09-19 09:13:20 -07001# To add another RMCPP interface, add similar lines to the
2# following lines in a bbappend:
3#
4# ALT_RMCPP_IFACE = "eth1"
5# SYSTEMD_SERVICE:${PN} += " \
6# ${PN}@${ALT_RMCPP_IFACE}.service \
7# ${PN}@${ALT_RMCPP_IFACE}.socket \
8# "
9# Also, be sure to enable a corresponding entry in the channel
10# config file with the same 'name' as the interfaces above
11# Override the default phosphor-ipmi-config.bb with a bbappend
Tom Joseph7b827742017-01-16 16:43:05 +053012SUMMARY = "Phosphor Network IPMI Daemon"
13DESCRIPTION = "Daemon to support IPMI protocol over network"
14HOMEPAGE = "https://github.com/openbmc/phosphor-net-ipmid"
Brad Bishop75f03872018-11-03 09:41:57 -070015LICENSE = "Apache-2.0"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Vernon Mauery3fcd42e2019-04-12 14:06:06 -070017DEPENDS += "cli11"
Patrick Williams0450a022022-10-07 21:23:47 -050018DEPENDS += "libmapper"
Tom Joseph7b827742017-01-16 16:43:05 +053019DEPENDS += "systemd"
20DEPENDS += "phosphor-ipmi-host"
Ed Tanous9936f862022-09-19 09:13:20 -070021SRCREV = "67aaec2e06ff9c2bfd5900b9f07834fca9d009f2"
22PV = "1.0+git${SRCPV}"
23PR = "r1"
Brad Bishopea413432020-08-10 20:18:26 -040024
Patrick Williamsbb99d222022-01-24 15:55:09 -060025SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid;branch=master;protocol=https"
Tom Joseph7b827742017-01-16 16:43:05 +053026
27S = "${WORKDIR}/git"
Ed Tanous9936f862022-09-19 09:13:20 -070028# install parameterized service and socket files
29SYSTEMD_SERVICE:${PN} = " \
30 ${PN}@${RMCPP_IFACE}.service \
31 ${PN}@${RMCPP_IFACE}.socket \
32 "
33
34inherit meson pkgconfig
35inherit systemd
Tom Joseph7b827742017-01-16 16:43:05 +053036
George Liu9d1e1c22022-08-08 10:39:05 +080037EXTRA_OEMESON = " \
38 -Dtests=disabled \
39 "
40
Ed Tanous9936f862022-09-19 09:13:20 -070041RRECOMMENDS:${PN} = "pam-ipmi"
42
Patrick Williams12fc9392021-08-06 09:16:53 -050043FILES:${PN} += " \
Vernon Mauery33136592019-03-22 12:25:14 -070044 ${systemd_system_unitdir}/${PN}@.service \
45 ${systemd_system_unitdir}/${PN}@.socket \
Tom Joseph62b03f22017-01-27 14:11:58 +053046 "
Vernon Mauery33136592019-03-22 12:25:14 -070047
48# If RMCPP_IFACE is not set by bbappend, set it to default
49DEFAULT_RMCPP_IFACE = "eth0"
50RMCPP_IFACE ?= "${DEFAULT_RMCPP_IFACE}"