blob: 3993e2f55ad15150f35af527a7bb760d41dd32c9 [file] [log] [blame]
Tom Joseph7b827742017-01-16 16:43:05 +05301SUMMARY = "Phosphor Network IPMI Daemon"
2DESCRIPTION = "Daemon to support IPMI protocol over network"
3HOMEPAGE = "https://github.com/openbmc/phosphor-net-ipmid"
4PR = "r1"
Patrick Ventureafba95a2018-10-01 20:54:34 -07005PV = "1.0+git${SRCPV}"
Brad Bishop75f03872018-11-03 09:41:57 -07006LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Tom Joseph7b827742017-01-16 16:43:05 +05308
9inherit autotools pkgconfig
Vernon Mauery33136592019-03-22 12:25:14 -070010inherit systemd
Tom Joseph7b827742017-01-16 16:43:05 +053011
12DEPENDS += "autoconf-archive-native"
Vernon Mauery3fcd42e2019-04-12 14:06:06 -070013DEPENDS += "cli11"
Tom Joseph7b827742017-01-16 16:43:05 +053014DEPENDS += "phosphor-mapper"
15DEPENDS += "systemd"
16DEPENDS += "phosphor-ipmi-host"
Tom Joseph7b827742017-01-16 16:43:05 +053017
Patrick Williams12fc9392021-08-06 09:16:53 -050018RRECOMMENDS:${PN} = "pam-ipmi"
Brad Bishopea413432020-08-10 20:18:26 -040019
Patrick Williamsbb99d222022-01-24 15:55:09 -060020SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid;branch=master;protocol=https"
Andrew Geissler38caf2d2021-12-06 22:00:56 +000021SRCREV = "af23add2a2cf73226cdc72af4793fde6357e8932"
Tom Joseph7b827742017-01-16 16:43:05 +053022
23S = "${WORKDIR}/git"
24
Patrick Williams12fc9392021-08-06 09:16:53 -050025FILES:${PN} += " \
Vernon Mauery33136592019-03-22 12:25:14 -070026 ${systemd_system_unitdir}/${PN}@.service \
27 ${systemd_system_unitdir}/${PN}@.socket \
Tom Joseph62b03f22017-01-27 14:11:58 +053028 "
Vernon Mauery33136592019-03-22 12:25:14 -070029
30# If RMCPP_IFACE is not set by bbappend, set it to default
31DEFAULT_RMCPP_IFACE = "eth0"
32RMCPP_IFACE ?= "${DEFAULT_RMCPP_IFACE}"
33
34# install parameterized service and socket files
Patrick Williams12fc9392021-08-06 09:16:53 -050035SYSTEMD_SERVICE:${PN} = " \
Vernon Mauery33136592019-03-22 12:25:14 -070036 ${PN}@${RMCPP_IFACE}.service \
37 ${PN}@${RMCPP_IFACE}.socket \
38 "
39
40# To add another RMCPP interface, add similar lines to the
41# following lines in a bbappend:
42#
43# ALT_RMCPP_IFACE = "eth1"
Patrick Williams12fc9392021-08-06 09:16:53 -050044# SYSTEMD_SERVICE:${PN} += " \
Vernon Mauery33136592019-03-22 12:25:14 -070045# ${PN}@${ALT_RMCPP_IFACE}.service \
46# ${PN}@${ALT_RMCPP_IFACE}.socket \
47# "
48
49# Also, be sure to enable a corresponding entry in the channel
50# config file with the same 'name' as the interfaces above
51# Override the default phosphor-ipmi-config.bb with a bbappend
52