blob: f54eb28c4fce7a65ee18bddd256f861b399c2fd2 [file] [log] [blame]
Tom Joseph7b827742017-01-16 16:43:05 +05301SUMMARY = "Phosphor Network IPMI Daemon"
2DESCRIPTION = "Daemon to support IPMI protocol over network"
3HOMEPAGE = "https://github.com/openbmc/phosphor-net-ipmid"
4PR = "r1"
Patrick Ventureafba95a2018-10-01 20:54:34 -07005PV = "1.0+git${SRCPV}"
Brad Bishop75f03872018-11-03 09:41:57 -07006LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Tom Joseph7b827742017-01-16 16:43:05 +05308
9inherit autotools pkgconfig
Tom Joseph7b827742017-01-16 16:43:05 +053010inherit obmc-phosphor-systemd
11
12DEPENDS += "autoconf-archive-native"
Vernon Mauery3fcd42e2019-04-12 14:06:06 -070013DEPENDS += "cli11"
Tom Joseph7b827742017-01-16 16:43:05 +053014DEPENDS += "phosphor-mapper"
15DEPENDS += "systemd"
16DEPENDS += "phosphor-ipmi-host"
Tom Joseph26b20722018-09-21 00:56:43 -050017RDEPENDS_${PN} += "iptables"
Tom Joseph7b827742017-01-16 16:43:05 +053018
19SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid"
Tom Joseph08589c22018-10-17 07:44:52 -050020SRC_URI += "file://ipmi-net-firewall.sh"
Andrew Geissler6f14d742019-04-02 08:32:35 +000021SRCREV = "8af90ebcc552e243ae85aa9e9da1a00fbecab56c"
Tom Joseph7b827742017-01-16 16:43:05 +053022
23S = "${WORKDIR}/git"
24
Tom Joseph08589c22018-10-17 07:44:52 -050025do_install_append() {
Patrick Venturef0821df2019-04-01 12:46:55 -070026 install -d ${D}${bindir}
Tom Joseph08589c22018-10-17 07:44:52 -050027 install -m 0755 ${WORKDIR}/ipmi-net-firewall.sh \
Patrick Venturef0821df2019-04-01 12:46:55 -070028 ${D}${bindir}/ipmi-net-firewall.sh
Tom Joseph08589c22018-10-17 07:44:52 -050029}
30
Tom Joseph62b03f22017-01-27 14:11:58 +053031SYSTEMD_SERVICE_${PN} = " \
32 ${PN}.service \
33 ${PN}.socket \
34 "