blob: 48ca112d80a761c74c5e7d6145ddef6d5582503a [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001inherit siteinfo python3native
Brad Bishop316dfdd2018-06-25 12:45:53 -04002
3DEPENDS_append = " meson-native ninja-native"
4
5# As Meson enforces out-of-tree builds we can just use cleandirs
6B = "${WORKDIR}/build"
7do_configure[cleandirs] = "${B}"
8
9# Where the meson.build build configuration is
10MESON_SOURCEPATH = "${S}"
11
12def noprefix(var, d):
13 return d.getVar(var).replace(d.getVar('prefix') + '/', '', 1)
14
15MESONOPTS = " --prefix ${prefix} \
16 --buildtype plain \
17 --bindir ${@noprefix('bindir', d)} \
18 --sbindir ${@noprefix('sbindir', d)} \
19 --datadir ${@noprefix('datadir', d)} \
20 --libdir ${@noprefix('libdir', d)} \
21 --libexecdir ${@noprefix('libexecdir', d)} \
22 --includedir ${@noprefix('includedir', d)} \
23 --mandir ${@noprefix('mandir', d)} \
24 --infodir ${@noprefix('infodir', d)} \
25 --sysconfdir ${sysconfdir} \
26 --localstatedir ${localstatedir} \
Brad Bishop08902b02019-08-20 09:16:51 -040027 --sharedstatedir ${sharedstatedir} "
Brad Bishop316dfdd2018-06-25 12:45:53 -040028
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029EXTRA_OEMESON_append = " ${PACKAGECONFIG_CONFARGS}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040030
31MESON_CROSS_FILE = ""
32MESON_CROSS_FILE_class-target = "--cross-file ${WORKDIR}/meson.cross"
33MESON_CROSS_FILE_class-nativesdk = "--cross-file ${WORKDIR}/meson.cross"
34
35def meson_array(var, d):
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080036 items = d.getVar(var).split()
37 return repr(items[0] if len(items) == 1 else items)
38
39# Map our ARCH values to what Meson expects:
40# http://mesonbuild.com/Reference-tables.html#cpu-families
41def meson_cpu_family(var, d):
42 import re
43 arch = d.getVar(var)
44 if arch == 'powerpc':
45 return 'ppc'
46 elif arch == 'powerpc64':
47 return 'ppc64'
Brad Bishop19323692019-04-05 15:28:33 -040048 elif arch == 'armeb':
49 return 'arm'
Brad Bishop15ae2502019-06-18 21:44:24 -040050 elif arch == 'aarch64_be':
51 return 'aarch64'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080052 elif arch == 'mipsel':
53 return 'mips'
Brad Bishop19323692019-04-05 15:28:33 -040054 elif arch == 'mips64el':
55 return 'mips64'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080056 elif re.match(r"i[3-6]86", arch):
57 return "x86"
58 else:
59 return arch
60
61def meson_endian(prefix, d):
62 arch, os = d.getVar(prefix + "_ARCH"), d.getVar(prefix + "_OS")
63 sitedata = siteinfo_data_for_machine(arch, os, d)
64 if "endian-little" in sitedata:
65 return "little"
66 elif "endian-big" in sitedata:
67 return "big"
68 else:
69 bb.fatal("Cannot determine endianism for %s-%s" % (arch, os))
Brad Bishop316dfdd2018-06-25 12:45:53 -040070
71addtask write_config before do_configure
Brad Bishop96ff1982019-08-19 13:50:42 -040072do_write_config[vardeps] += "CC CXX LD AR NM STRIP READELF CFLAGS CXXFLAGS LDFLAGS"
Brad Bishop316dfdd2018-06-25 12:45:53 -040073do_write_config() {
74 # This needs to be Py to split the args into single-element lists
75 cat >${WORKDIR}/meson.cross <<EOF
76[binaries]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080077c = ${@meson_array('CC', d)}
78cpp = ${@meson_array('CXX', d)}
79ar = ${@meson_array('AR', d)}
80nm = ${@meson_array('NM', d)}
81ld = ${@meson_array('LD', d)}
82strip = ${@meson_array('STRIP', d)}
83readelf = ${@meson_array('READELF', d)}
Brad Bishop316dfdd2018-06-25 12:45:53 -040084pkgconfig = 'pkg-config'
Brad Bishop08902b02019-08-20 09:16:51 -040085llvm-config = 'llvm-config${LLVMVERSION}'
Brad Bishop316dfdd2018-06-25 12:45:53 -040086
87[properties]
88needs_exe_wrapper = true
Brad Bishop96ff1982019-08-19 13:50:42 -040089c_args = ${@meson_array('CFLAGS', d)}
90c_link_args = ${@meson_array('LDFLAGS', d)}
91cpp_args = ${@meson_array('CXXFLAGS', d)}
92cpp_link_args = ${@meson_array('LDFLAGS', d)}
Brad Bishop316dfdd2018-06-25 12:45:53 -040093gtkdoc_exe_wrapper = '${B}/gtkdoc-qemuwrapper'
94
95[host_machine]
96system = '${HOST_OS}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080097cpu_family = '${@meson_cpu_family('HOST_ARCH', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -040098cpu = '${HOST_ARCH}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080099endian = '${@meson_endian('HOST', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400100
101[target_machine]
102system = '${TARGET_OS}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800103cpu_family = '${@meson_cpu_family('TARGET_ARCH', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400104cpu = '${TARGET_ARCH}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800105endian = '${@meson_endian('TARGET', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400106EOF
107}
108
109CONFIGURE_FILES = "meson.build"
110
111meson_do_configure() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800112 # Work around "Meson fails if /tmp is mounted with noexec #2972"
113 mkdir -p "${B}/meson-private/tmp"
114 export TMPDIR="${B}/meson-private/tmp"
115 bbnote Executing meson ${EXTRA_OEMESON}...
Brad Bishop316dfdd2018-06-25 12:45:53 -0400116 if ! meson ${MESONOPTS} "${MESON_SOURCEPATH}" "${B}" ${MESON_CROSS_FILE} ${EXTRA_OEMESON}; then
Brad Bishop316dfdd2018-06-25 12:45:53 -0400117 bbfatal_log meson failed
118 fi
119}
120
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800121override_native_tools() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400122 # Set these so that meson uses the native tools for its build sanity tests,
123 # which require executables to be runnable. The cross file will still
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800124 # override these for the target build.
Brad Bishop316dfdd2018-06-25 12:45:53 -0400125 export CC="${BUILD_CC}"
126 export CXX="${BUILD_CXX}"
127 export LD="${BUILD_LD}"
128 export AR="${BUILD_AR}"
Brad Bishop96ff1982019-08-19 13:50:42 -0400129 export STRIP="${BUILD_STRIP}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800130 # These contain *target* flags but will be used as *native* flags. The
131 # correct native flags will be passed via -Dc_args and so on, unset them so
132 # they don't interfere with tools invoked by Meson (such as g-ir-scanner)
133 unset CPPFLAGS CFLAGS CXXFLAGS LDFLAGS
134}
135
136meson_do_configure_prepend_class-target() {
137 override_native_tools
Brad Bishop316dfdd2018-06-25 12:45:53 -0400138}
139
140meson_do_configure_prepend_class-nativesdk() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800141 override_native_tools
Brad Bishop316dfdd2018-06-25 12:45:53 -0400142}
143
144meson_do_configure_prepend_class-native() {
145 export PKG_CONFIG="pkg-config-native"
146}
147
148do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+"
149meson_do_compile() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800150 ninja -v ${PARALLEL_MAKE}
Brad Bishop316dfdd2018-06-25 12:45:53 -0400151}
152
153meson_do_install() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800154 DESTDIR='${D}' ninja -v ${PARALLEL_MAKEINST} install
Brad Bishop316dfdd2018-06-25 12:45:53 -0400155}
156
157EXPORT_FUNCTIONS do_configure do_compile do_install