blob: 278eeedc7416f1c18ea897dbd58f9597f506b9a9 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001# reproducible_build.bbclass
2#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08003# Sets SOURCE_DATE_EPOCH in each component's build environment.
4# Upstream components (generally) respect this environment variable,
5# using it in place of the "current" date and time.
6# See https://reproducible-builds.org/specs/source-date-epoch/
Brad Bishop316dfdd2018-06-25 12:45:53 -04007#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008# After sources are unpacked but before they are patched, we set a reproducible value for SOURCE_DATE_EPOCH.
9# This value should be reproducible for anyone who builds the same revision from the same sources.
Brad Bishop316dfdd2018-06-25 12:45:53 -040010#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011# There are 4 ways we determine SOURCE_DATE_EPOCH:
Brad Bishop316dfdd2018-06-25 12:45:53 -040012#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013# 1. Use the value from __source_date_epoch.txt file if this file exists.
14# This file was most likely created in the previous build by one of the following methods 2,3,4.
15# Alternatively, it can be provided by a recipe via SRC_URI.
Brad Bishop316dfdd2018-06-25 12:45:53 -040016#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017# If the file does not exist:
18#
19# 2. If there is a git checkout, use the last git commit timestamp.
20# Git does not preserve file timestamps on checkout.
Brad Bishop316dfdd2018-06-25 12:45:53 -040021#
22# 3. Use the mtime of "known" files such as NEWS, CHANGLELOG, ...
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023# This works for well-kept repositories distributed via tarball.
Brad Bishop316dfdd2018-06-25 12:45:53 -040024#
Brad Bishopa5c52ff2018-11-23 10:55:50 +130025# 4. Use the modification time of the youngest file in the source tree, if there is one.
26# This will be the newest file from the distribution tarball, if any.
27#
28# 5. Fall back to a fixed timestamp.
Brad Bishop316dfdd2018-06-25 12:45:53 -040029#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030# Once the value of SOURCE_DATE_EPOCH is determined, it is stored in the recipe's SDE_FILE.
31# If none of these mechanisms are suitable, replace the do_deploy_source_date_epoch task
32# with recipe-specific functionality to write the appropriate SOURCE_DATE_EPOCH into the SDE_FILE.
33#
34# If this file is found by other tasks, the value is exported in the SOURCE_DATE_EPOCH variable.
35# SOURCE_DATE_EPOCH is set for all tasks that might use it (do_configure, do_compile, do_package, ...)
Brad Bishop316dfdd2018-06-25 12:45:53 -040036
37BUILD_REPRODUCIBLE_BINARIES ??= '1'
38inherit ${@oe.utils.ifelse(d.getVar('BUILD_REPRODUCIBLE_BINARIES') == '1', 'reproducible_build_simple', '')}
39
Andrew Geissler90fd73c2021-03-05 15:25:55 -060040SDE_DIR = "${WORKDIR}/source-date-epoch"
Brad Bishop316dfdd2018-06-25 12:45:53 -040041SDE_FILE = "${SDE_DIR}/__source_date_epoch.txt"
Brad Bishop00e122a2019-10-05 11:10:57 -040042SDE_DEPLOYDIR = "${WORKDIR}/deploy-source-date-epoch"
Brad Bishop316dfdd2018-06-25 12:45:53 -040043
Andrew Geisslerc926e172021-05-07 16:11:35 -050044# Enable compiler warning when the __TIME__, __DATE__ and __TIMESTAMP__ macros are used.
45TARGET_CC_ARCH_append_class-target = " -Wdate-time"
46
Andrew Geissler90fd73c2021-03-05 15:25:55 -060047# A SOURCE_DATE_EPOCH of '0' might be misinterpreted as no SDE
48export SOURCE_DATE_EPOCH_FALLBACK ??= "1302044400"
49
Brad Bishop316dfdd2018-06-25 12:45:53 -040050SSTATETASKS += "do_deploy_source_date_epoch"
51
52do_deploy_source_date_epoch () {
Brad Bishop00e122a2019-10-05 11:10:57 -040053 mkdir -p ${SDE_DEPLOYDIR}
54 if [ -e ${SDE_FILE} ]; then
Andrew Geissler82c905d2020-04-13 13:39:40 -050055 echo "Deploying SDE from ${SDE_FILE} -> ${SDE_DEPLOYDIR}."
Brad Bishop00e122a2019-10-05 11:10:57 -040056 cp -p ${SDE_FILE} ${SDE_DEPLOYDIR}/__source_date_epoch.txt
Andrew Geissler82c905d2020-04-13 13:39:40 -050057 else
58 echo "${SDE_FILE} not found!"
Brad Bishop00e122a2019-10-05 11:10:57 -040059 fi
Brad Bishop316dfdd2018-06-25 12:45:53 -040060}
61
62python do_deploy_source_date_epoch_setscene () {
63 sstate_setscene(d)
Brad Bishop00e122a2019-10-05 11:10:57 -040064 bb.utils.mkdirhier(d.getVar('SDE_DIR'))
65 sde_file = os.path.join(d.getVar('SDE_DEPLOYDIR'), '__source_date_epoch.txt')
66 if os.path.exists(sde_file):
Andrew Geissler82c905d2020-04-13 13:39:40 -050067 target = d.getVar('SDE_FILE')
68 bb.debug(1, "Moving setscene SDE file %s -> %s" % (sde_file, target))
Andrew Geisslerc926e172021-05-07 16:11:35 -050069 bb.utils.rename(sde_file, target)
Andrew Geissler82c905d2020-04-13 13:39:40 -050070 else:
71 bb.debug(1, "%s not found!" % sde_file)
Brad Bishop316dfdd2018-06-25 12:45:53 -040072}
73
Brad Bishop00e122a2019-10-05 11:10:57 -040074do_deploy_source_date_epoch[dirs] = "${SDE_DEPLOYDIR}"
75do_deploy_source_date_epoch[sstate-plaindirs] = "${SDE_DEPLOYDIR}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040076addtask do_deploy_source_date_epoch_setscene
77addtask do_deploy_source_date_epoch before do_configure after do_patch
78
Andrew Geissler82c905d2020-04-13 13:39:40 -050079python create_source_date_epoch_stamp() {
Andrew Geisslerb7d28612020-07-24 16:15:54 -050080 import oe.reproducible
81
Brad Bishop316dfdd2018-06-25 12:45:53 -040082 epochfile = d.getVar('SDE_FILE')
Andrew Geissler09036742021-06-25 14:25:14 -050083 tmp_file = "%s.new" % epochfile
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080084
Andrew Geisslerb7d28612020-07-24 16:15:54 -050085 source_date_epoch = oe.reproducible.get_source_date_epoch(d, d.getVar('S'))
Brad Bishop316dfdd2018-06-25 12:45:53 -040086
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080087 bb.debug(1, "SOURCE_DATE_EPOCH: %d" % source_date_epoch)
Brad Bishop316dfdd2018-06-25 12:45:53 -040088 bb.utils.mkdirhier(d.getVar('SDE_DIR'))
Andrew Geissler09036742021-06-25 14:25:14 -050089 with open(tmp_file, 'w') as f:
Brad Bishop316dfdd2018-06-25 12:45:53 -040090 f.write(str(source_date_epoch))
Andrew Geissler09036742021-06-25 14:25:14 -050091
92 os.rename(tmp_file, epochfile)
Brad Bishop316dfdd2018-06-25 12:45:53 -040093}
94
Andrew Geissler82c905d2020-04-13 13:39:40 -050095def get_source_date_epoch_value(d):
96 cached = d.getVar('__CACHED_SOURCE_DATE_EPOCH')
97 if cached:
98 return cached
99
100 epochfile = d.getVar('SDE_FILE')
Andrew Geissler90fd73c2021-03-05 15:25:55 -0600101 source_date_epoch = int(d.getVar('SOURCE_DATE_EPOCH_FALLBACK'))
Andrew Geissler09036742021-06-25 14:25:14 -0500102 try:
Andrew Geissler82c905d2020-04-13 13:39:40 -0500103 with open(epochfile, 'r') as f:
104 s = f.read()
105 try:
106 source_date_epoch = int(s)
Andrew Geissler90fd73c2021-03-05 15:25:55 -0600107 # workaround for old sstate with SDE_FILE content being 0 - use SOURCE_DATE_EPOCH_FALLBACK
108 if source_date_epoch == 0 :
109 source_date_epoch = int(d.getVar('SOURCE_DATE_EPOCH_FALLBACK'))
110 bb.warn("SOURCE_DATE_EPOCH value from sstate '%s' is deprecated/invalid. Reverting to SOURCE_DATE_EPOCH_FALLBACK '%s'" % (s, source_date_epoch))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500111 except ValueError:
Andrew Geissler90fd73c2021-03-05 15:25:55 -0600112 bb.warn("SOURCE_DATE_EPOCH value '%s' is invalid. Reverting to SOURCE_DATE_EPOCH_FALLBACK" % s)
113 source_date_epoch = int(d.getVar('SOURCE_DATE_EPOCH_FALLBACK'))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500114 bb.debug(1, "SOURCE_DATE_EPOCH: %d" % source_date_epoch)
Andrew Geissler09036742021-06-25 14:25:14 -0500115 except FileNotFoundError:
Andrew Geissler82c905d2020-04-13 13:39:40 -0500116 bb.debug(1, "Cannot find %s. SOURCE_DATE_EPOCH will default to %d" % (epochfile, source_date_epoch))
117
118 d.setVar('__CACHED_SOURCE_DATE_EPOCH', str(source_date_epoch))
119 return str(source_date_epoch)
120
121export SOURCE_DATE_EPOCH ?= "${@get_source_date_epoch_value(d)}"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400122BB_HASHBASE_WHITELIST += "SOURCE_DATE_EPOCH"
123
124python () {
125 if d.getVar('BUILD_REPRODUCIBLE_BINARIES') == '1':
Andrew Geissler82c905d2020-04-13 13:39:40 -0500126 d.appendVarFlag("do_unpack", "postfuncs", " create_source_date_epoch_stamp")
Brad Bishop316dfdd2018-06-25 12:45:53 -0400127}