Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Default display timings and resolutions for fbset" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 2 | HOMEPAGE = "http://users.telenet.be/geertu/Linux/fbdev/" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 5 | |
| 6 | PV = "0.1.0" |
| 7 | PR = "r6" |
| 8 | |
| 9 | SRC_URI = "file://fb.modes" |
| 10 | S = "${WORKDIR}" |
| 11 | |
| 12 | do_install() { |
| 13 | install -d ${D}${sysconfdir} |
| 14 | install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir} |
| 15 | } |
| 16 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | # fb.modes file is MACHINE_ARCH, base.bbclass correctly changes it to MACHINE_ARCH, but too late for allarch.bbclass |
| 18 | # to disable "all" behavior (found when comparing qemuarm and qemux86 signatures) |
| 19 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 20 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | CONFFILES:${PN} = "${sysconfdir}/fb.modes" |