blob: b76ed2477fd1f5ce811f483ee39cf87c636ed383 [file] [log] [blame]
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -05001SUMMARY = "Userspace utilities for fs-verity"
2DESCRIPTION = "fs-verity is a Linux kernel feature that does transparent \
3on-demand integrity/authenticity verification of the contents of read-only \
4files, using a hidden Merkle tree (hash tree) associated with the file. The \
5mechanism is similar to dm-verity, but implemented at the file level rather \
6than at the block device level."
7HOMEPAGE = "https://www.kernel.org/doc/html/latest/filesystems/fsverity.html"
8SECTION = "console"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=bc974d217b525ea216a336adb73e1220"
11
Andrew Geissler69721092021-07-23 12:57:00 -040012SRCREV = "9e082897d61a2449657651aa5a0931aca31428fd"
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/ebiggers/fsverity-utils.git;branch=master"
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050014
15S = "${WORKDIR}/git"
16
17DEPENDS = "openssl"
18
Patrick Williams213cb262021-08-07 19:21:33 -050019EXTRA_OEMAKE:append = "PREFIX=${prefix} USE_SHARED_LIB=1"
Andrew Geisslereef63862021-01-29 15:58:13 -060020# We want to statically link the binary to libfsverity on native Windows
Patrick Williams213cb262021-08-07 19:21:33 -050021EXTRA_OEMAKE:remove:mingw32:class-nativesdk = "USE_SHARED_LIB=1"
22EXTRA_OEMAKE:remove:mingw32:class-native = "USE_SHARED_LIB=1"
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050023
24do_install() {
25 oe_runmake install DESTDIR=${D}
26}
27
28PACKAGES =+ "libfsverity"
Patrick Williams213cb262021-08-07 19:21:33 -050029FILES:libfsverity = "${libdir}/libfsverity*${SOLIBS}"
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050030
31BBCLASSEXTEND = "native nativesdk"