Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Linux encrypted filesystem management tool" |
| 2 | HOMEPAGE = "http://cryptmount.sourceforge.net/" |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://README;beginline=3;endline=4;md5=dae0772f0ff46fd927e7fdb08af51b71" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 4 | LICENSE = "GPL-2.0-only" |
| 5 | |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 6 | SRC_URI = "https://sourceforge.net/projects/cryptmount/files/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.gz \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 7 | " |
| 8 | |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "86528a9175e1eb53f60613e3c3ea6ae6d69dbfe5ac2b53b2f58ba0f768371e7e" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 10 | |
| 11 | inherit autotools-brokensep gettext pkgconfig systemd |
| 12 | |
| 13 | EXTRA_OECONF = " --enable-cswap --enable-fsck --enable-argv0switch" |
| 14 | |
| 15 | PACKAGECONFIG ?="intl luks gcrypt nls" |
| 16 | PACKAGECONFIG:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" |
| 17 | |
| 18 | PACKAGECONFIG[systemd] = "--with-systemd, --without-systemd, systemd" |
| 19 | PACKAGECONFIG[intl] = "--with-libintl-prefix, --without-libintl-prefix" |
| 20 | PACKAGECONFIG[gcrypt] = "--with-libgcrypt, --without-libgcrypt, libgcrypt" |
| 21 | PACKAGECONFIG[luks] = "--enable-luks, --disable-luks, cryptsetup" |
| 22 | PACKAGECONFIG[nls] = "--enable-nls, --disable-nls, " |
| 23 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 24 | SYSTEMD_PACKAGES = "${PN}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 25 | SYSTEMD_SERVICE:${PN} = "cryptmount.service" |
| 26 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 27 | do_install:append () { |
| 28 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 29 | install -D -m 0644 ${S}/sysinit/cryptmount.service ${D}${systemd_system_unitdir}/cryptmount.service |
| 30 | rm -fr ${D}/usr/lib |
| 31 | fi |
| 32 | } |
| 33 | |
| 34 | FILES:${PN} += "${systemd_system_unitdir}" |
| 35 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 36 | RDEPENDS:${PN} = "libdevmapper" |