blob: ff8ce7993580b8317294ca89011cf4a4ffa2ce28 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001python __anonymous() {
2 if "linux-raspberrypi-dev" not in d.getVar("PREFERRED_PROVIDER_virtual/kernel"):
3 msg = "Skipping linux-raspberrypi-dev as it is not the preferred " + \
4 "provider of virtual/kernel."
5 raise bb.parse.SkipRecipe(msg)
6}
7
Andrew Geissler26e4bea2020-11-30 19:54:03 -06008LINUX_VERSION ?= "5.10.y"
9LINUX_RPI_BRANCH ?= "rpi-5.10.y"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010
Andrew Geissler26e4bea2020-11-30 19:54:03 -060011SRCREV_machine = "${AUTOREV}"
12SRCREV_meta = "${AUTOREV}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013
Andrew Geissler26e4bea2020-11-30 19:54:03 -060014KMETA = "kernel-meta"
15
Brad Bishop316dfdd2018-06-25 12:45:53 -040016SRC_URI = " \
Andrew Geissler26e4bea2020-11-30 19:54:03 -060017 git://github.com/raspberrypi/linux.git;name=machine;protocol=git;branch=${LINUX_RPI_BRANCH} \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=master;destsuffix=${KMETA} \
19 file://powersave.cfg \
20 file://android-drivers.cfg \
Brad Bishop316dfdd2018-06-25 12:45:53 -040021 "
Andrew Geissler26e4bea2020-11-30 19:54:03 -060022
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023require linux-raspberrypi.inc
24
Andrew Geissler11105212021-02-12 15:30:38 -060025KERNEL_DTC_FLAGS += "-@ -H epapr"
Andrew Geissler26e4bea2020-11-30 19:54:03 -060026
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027# Disable version check so that we don't have to edit this recipe every time
28# upstream bumps the version
29KERNEL_VERSION_SANITY_SKIP = "1"