Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "An asynchronous event notification library" |
| 2 | HOMEPAGE = "http://libevent.org/" |
| 3 | BUGTRACKER = "https://github.com/libevent/libevent/issues" |
| 4 | SECTION = "libs" |
| 5 | |
| 6 | LICENSE = "BSD & MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=17f20574c0b154d12236d5fbe964f549" |
| 8 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | SRC_URI = "https://github.com/libevent/libevent/releases/download/release-${PV}-stable/${BP}-stable.tar.gz \ |
| 10 | file://Makefile-missing-test-dir.patch \ |
| 11 | file://run-ptest \ |
| 12 | file://0001-test-regress_dns.c-patch-out-tests-that-require-a-wo.patch \ |
| 13 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 14 | |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "92e6de1be9ec176428fd2367677e61ceffc2ee1cb119035037a27d346b0403bb" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 16 | |
| 17 | UPSTREAM_CHECK_URI = "http://libevent.org/" |
| 18 | |
| 19 | S = "${WORKDIR}/${BPN}-${PV}-stable" |
| 20 | |
| 21 | PACKAGECONFIG ??= "" |
| 22 | PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" |
| 23 | |
| 24 | inherit autotools |
| 25 | |
| 26 | # Needed for Debian packaging |
| 27 | LEAD_SONAME = "libevent-2.1.so" |
| 28 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | inherit ptest multilib_header |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 30 | |
| 31 | DEPENDS = "zlib" |
| 32 | |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 33 | PACKAGES_DYNAMIC = "^${PN}-.*$" |
| 34 | python split_libevent_libs () { |
| 35 | do_split_packages(d, '${libdir}', r'^libevent_([a-z]*)-.*\.so\..*', '${PN}-%s', '${SUMMARY} (%s)', prepend=True, allow_links=True) |
| 36 | } |
| 37 | PACKAGESPLITFUNCS_prepend = "split_libevent_libs " |
| 38 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 39 | BBCLASSEXTEND = "native nativesdk" |
| 40 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 41 | do_install_append() { |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 42 | rm ${D}${bindir}/event_rpcgen.py |
| 43 | rmdir ${D}${bindir} |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 44 | oe_multilib_header event2/event-config.h |
| 45 | } |
| 46 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 47 | do_install_ptest() { |
| 48 | install -d ${D}${PTEST_PATH}/test |
| 49 | for file in ${B}/test/.libs/regress ${B}/test/.libs/test* |
| 50 | do |
| 51 | install -m 0755 $file ${D}${PTEST_PATH}/test |
| 52 | done |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 53 | |
| 54 | # handle multilib |
| 55 | sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 56 | } |