Andrew Geissler | f1e4406 | 2021-04-15 15:52:46 -0500 | [diff] [blame] | 1 | SUMMARY = "Parsec Command Line Interface" |
| 2 | HOMEPAGE = "https://github.com/parallaxsecond/parsec-tool" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | |
| 5 | inherit cargo |
| 6 | |
| 7 | SRC_URI += "crate://crates.io/parsec-tool/${PV} \ |
| 8 | " |
| 9 | |
Patrick Williams | 93c203f | 2021-10-06 16:15:23 -0500 | [diff] [blame] | 10 | RDEPENDS:${PN} = "openssl-bin" |
| 11 | |
Andrew Geissler | f1e4406 | 2021-04-15 15:52:46 -0500 | [diff] [blame] | 12 | do_install() { |
| 13 | install -d ${D}/${bindir} |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 14 | install -m 755 "${B}/target/${CARGO_TARGET_SUBDIR}/parsec-tool" "${D}${bindir}/parsec-tool" |
Patrick Williams | 93c203f | 2021-10-06 16:15:23 -0500 | [diff] [blame] | 15 | install -m 755 "${S}/tests/parsec-cli-tests.sh" "${D}${bindir}/parsec-cli-tests.sh" |
Andrew Geissler | f1e4406 | 2021-04-15 15:52:46 -0500 | [diff] [blame] | 16 | } |
| 17 | |
| 18 | require parsec-tool_${PV}.inc |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 19 | |
| 20 | # The QA check has been temporarily disabled. An issue has been created |
| 21 | # upstream to fix this. |
| 22 | # https://github.com/parallaxsecond/parsec-tool/issues/94 |
| 23 | INSANE_SKIP:${PN}-dbg += "buildpaths" |