blob: 4363d4c0a2e0e698fbdc11922534ae6549bce9d9 [file] [log] [blame]
Vijay Khemka66070d32020-07-23 15:22:56 -07001SUMMARY = "BMC Health Monitoring"
2DESCRIPTION = "Daemon to collect and monitor bmc health statistics"
3HOMEPAGE = "https://github.com/openbmc/phosphor-health-monitor"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
7
8inherit meson pkgconfig
9inherit systemd
10
11DEPENDS += "sdbusplus"
12DEPENDS += "phosphor-dbus-interfaces"
13DEPENDS += "sdeventplus"
14DEPENDS += "phosphor-logging"
15DEPENDS += "nlohmann-json"
16
17SRC_URI = "git://github.com/openbmc/phosphor-health-monitor.git;protocol=git"
Andrew Geisslerc0fb1da2020-12-04 15:13:00 +000018SRCREV = "2b231e8aa91a76a7c36f1c70c7e4058a38d0a5f1"
Vijay Khemka66070d32020-07-23 15:22:56 -070019S = "${WORKDIR}/git"
20
Patrick Williams12fc9392021-08-06 09:16:53 -050021SYSTEMD_SERVICE:${PN} = "phosphor-health-monitor.service"