blob: 160508ec22f7fe4a387410c916318787095c5b3a [file] [log] [blame]
Brad Bishope3278032016-11-09 20:43:11 -05001SUMMARY = "C++ bindings for systemd dbus APIs"
2DESCRIPTION = "C++ bindings for systemd dbus APIs."
3HOMEPAGE = "http://github.com/openbmc/sdbusplus"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
8inherit autotools pkgconfig
Patrick Williams8fc96292016-11-22 07:01:14 -06009inherit obmc-phosphor-python-autotools
Brad Bishope3278032016-11-09 20:43:11 -050010
11DEPENDS += "autoconf-archive-native"
Brad Bishop13b8afa2017-01-12 14:06:43 -050012RDEPENDS_sdbus++ += " \
Brad Bishope3278032016-11-09 20:43:11 -050013 python-inflection \
14 python-mako \
15 python-pyyaml \
16 "
17
18SRC_URI += "git://github.com/openbmc/sdbusplus"
Patrick Williams94a0a842017-01-09 21:40:02 -060019SRCREV = "aa2e7f7170327511110a448c1314a1ef2195ee25"
Brad Bishope3278032016-11-09 20:43:11 -050020
21PACKAGECONFIG ??= "libsdbusplus"
22PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
23
24S = "${WORKDIR}/git"
25
Patrick Williams592d7982016-11-22 11:05:11 -060026PROVIDES_prepend = "sdbus++ "
27PACKAGES_prepend = "sdbus++ "
28FILES_sdbus++_append = " ${bindir}/sdbus++"
29PYTHON_AUTOTOOLS_PACKAGE = "sdbus++"
30
Brad Bishope3278032016-11-09 20:43:11 -050031PACKAGECONFIG_remove_class-native = "libsdbusplus"
32PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus"
Patrick Williams56d9b5d2016-11-22 13:28:33 -060033ALLOW_EMPTY_${PN} = "1"
Brad Bishope3278032016-11-09 20:43:11 -050034
Brad Bishope3278032016-11-09 20:43:11 -050035BBCLASSEXTEND += "native nativesdk"