blob: fb166df607cfd9735fc97e53042ad11620de0d35 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "ISC Kea DHCP Server"
2DESCRIPTION = "Kea is the next generation of DHCP software developed by ISC. It supports both DHCPv4 and DHCPv6 protocols along with their extensions, e.g. prefix delegation and dynamic updates to DNS."
3HOMEPAGE = "http://kea.isc.org"
4SECTION = "connectivity"
5LICENSE = "MPL-2.0 & Apache-2.0"
Brad Bishop15ae2502019-06-18 21:44:24 -04006LIC_FILES_CHKSUM = "file://COPYING;md5=2ed44ce4e0bbfdc1abfa6bf949b7ba3a"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007
8DEPENDS += "kea-native"
9
10SRC_URI = "\
11 http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \
12 file://0003-Makefile.am-update-hooksdir-for-lease_cmds.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040013 file://0001-remove-AC_TRY_RUN.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014 file://kea-dhcp4.service \
15 file://kea-dhcp6.service \
16 file://kea-dhcp-ddns.service \
17"
Brad Bishop15ae2502019-06-18 21:44:24 -040018SRC_URI[md5sum] = "591d38e5fcc0251a8812e8bb1337578a"
19SRC_URI[sha256sum] = "edce4fab68ca7af607cf7f5bc86596e04fe0ef4b8e88906e339cdefcf21daaec"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
21inherit autotools systemd
22
23SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service"
24SYSTEMD_AUTO_ENABLE = "disable"
25
Brad Bishop15ae2502019-06-18 21:44:24 -040026DEBUG_OPTIMIZATION_remove_mips = " -Og"
27DEBUG_OPTIMIZATION_append_mips = " -O"
28BUILD_OPTIMIZATION_remove_mips = " -Og"
29BUILD_OPTIMIZATION_append_mips = " -O"
30
31DEBUG_OPTIMIZATION_remove_mipsel = " -Og"
32DEBUG_OPTIMIZATION_append_mipsel = " -O"
33BUILD_OPTIMIZATION_remove_mipsel = " -Og"
34BUILD_OPTIMIZATION_append_mipsel = " -O"
35
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080036do_configure_prepend_class-target() {
37 mkdir -p ${B}/src/lib/log/compiler/
38 ln -sf ${STAGING_BINDIR_NATIVE}/kea-msg-compiler ${B}/src/lib/log/compiler/kea-msg-compiler
39}
40
41do_install_append_class-target() {
42 install -d ${D}${systemd_system_unitdir}
43 install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir}
44 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \
45 -e 's,@LOCALSTATEDIR@,${localstatedir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' \
46 ${D}${systemd_system_unitdir}/kea-dhcp*service
47}
48
49do_install_append() {
50 rm -rf "${D}${localstatedir}"
51}
52
53PACKAGECONFIG ??= "openssl log4cplus boost"
54
55PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_TARGET}${prefix},,openssl,openssl"
56PACKAGECONFIG[log4cplus] = "--with-log4cplus=${STAGING_DIR_TARGET}${prefix},,log4cplus,log4cplus"
57PACKAGECONFIG[boost] = "--with-boost-include=${STAGING_INCDIR} --with-boost-lib-dir=${STAGING_LIBDIR} --with-boost-libs=-lboost_system,,boost,boost"
58
59FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a"
60FILES_${PN} += "${libdir}/hooks/*.so"
61
62BBCLASSEXTEND += "native"