blob: c44ee6340c477467e9df91a72dd93efdb6559661 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Skip tests when modules not available"
2DESCRIPTION = "Skip test scripts if modules are not available. \
3The requested modules will be loaded, and optionally have their versions \
4checked. If the module is missing, the test script will be skipped. Modules \
5that are found but fail to compile will exit with an error rather than skip."
6
7HOMEPAGE = "https://metacpan.org/release/Test-Needs"
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10
11CPAN_NAME = "Test-Needs"
12CPAN_AUTHOR = "HAARG"
13
Brad Bishop393846f2019-05-20 12:24:11 -040014LIC_FILES_CHKSUM = "file://README;md5=3f3ccd21a0a48aa313db212cc3b1bc09;beginline=88;endline=89"
Brad Bishop316dfdd2018-06-25 12:45:53 -040015
16DEPENDS += "perl"
17
Brad Bishop393846f2019-05-20 12:24:11 -040018SRC_URI = "https://cpan.metacpan.org/authors/id/H/HA/${CPAN_AUTHOR}/${CPAN_NAME}-${PV}.tar.gz"
Brad Bishop316dfdd2018-06-25 12:45:53 -040019
Brad Bishop393846f2019-05-20 12:24:11 -040020SRC_URI[md5sum] = "d5c96d51d8d5510f7c0b7f354c49af1c"
21SRC_URI[sha256sum] = "77f9fff0c96c5e09f34d0416b3533c3319f7cd0bb1f7fe8f8072ad59f433f0e5"
Brad Bishop316dfdd2018-06-25 12:45:53 -040022
23S = "${WORKDIR}/${CPAN_NAME}-${PV}"
24
25inherit cpan ptest-perl
26
Brad Bishop15ae2502019-06-18 21:44:24 -040027RDEPENDS_${PN}-ptest += "perl-module-test-more perl-module-ipc-open3 perl-module-lib perl-module-version"
Brad Bishop316dfdd2018-06-25 12:45:53 -040028
29BBCLASSEXTEND = "native"