blob: 477af8ced06fcefcddd6d2414408488480420989 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \
2server for multi-processor machines. It is a new implementation of the \
3JACK server core features that aims in removing some limitations of \
4the JACK1 design. The activation system has been changed for a data \
5flow model and lock-free programming techniques for graph access have \
6been used to have a more dynamic and robust system."
7SECTION = "libs/multimedia"
8
9LICENSE = "GPLv2 & LGPLv2.1"
10LIC_FILES_CHKSUM = " \
11 file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \
12 file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \
13"
14
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015DEPENDS = "libsamplerate0 libsndfile1 readline"
Patrick Williamsddad1a12017-02-23 20:36:32 -060016
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017SRC_URI = "git://github.com/jackaudio/jack2.git \
18 file://0001-Python-3.7-fixes-2126.patch \
Brad Bishop19323692019-04-05 15:28:33 -040019 file://0001-Fix-OSX-build.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040021SRCREV = "c1647819eed6d11f94b21981d9c869629299f357"
22PV = "1.9.12"
Patrick Williamsddad1a12017-02-23 20:36:32 -060023S = "${WORKDIR}/git"
24
25inherit waf pkgconfig
26
27PACKAGECONFIG ??= "alsa"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib"
Brad Bishop19323692019-04-05 15:28:33 -040029# --dbus only stops building jackd -> add --classic
30PACKAGECONFIG[dbus] = "--dbus --classic,,dbus"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus"
Patrick Williamsddad1a12017-02-23 20:36:32 -060032
33# portaudio is for windows builds only
34EXTRA_OECONF = "--portaudio=no"
35
36PACKAGES =+ "libjack jack-server jack-utils"
37
Brad Bishop6e60e8b2018-02-01 10:27:11 -050038RDEPENDS_jack-dev_remove = "${PN} (= ${EXTENDPKGV})"
39
Patrick Williamsddad1a12017-02-23 20:36:32 -060040FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
Brad Bishop19323692019-04-05 15:28:33 -040041FILES_jack-server = " \
42 ${datadir}/dbus-1/services \
43 ${bindir}/jackdbus \
44 ${bindir}/jackd \
45"
Patrick Williamsddad1a12017-02-23 20:36:32 -060046FILES_jack-utils = "${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -040047
Patrick Williamsddad1a12017-02-23 20:36:32 -060048FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/* "