blob: 6059ae95e0d87b76c258689ed2bcff314a144518 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001OE_TERMINAL ?= 'auto'
2OE_TERMINAL[type] = 'choice'
3OE_TERMINAL[choices] = 'auto none \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05004 ${@oe_terminal_prioritized()}'
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006OE_TERMINAL_EXPORTS += 'EXTRA_OEMAKE CACHED_CONFIGUREVARS CONFIGUREOPTS EXTRA_OECONF'
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007OE_TERMINAL_EXPORTS[type] = 'list'
8
9XAUTHORITY ?= "${HOME}/.Xauthority"
10SHELL ?= "bash"
11
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050012def oe_terminal_prioritized():
13 import oe.terminal
14 return " ".join(o.name for o in oe.terminal.prioritized())
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015
16def emit_terminal_func(command, envdata, d):
Brad Bishop19323692019-04-05 15:28:33 -040017 import bb.build
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018 cmd_func = 'do_terminal'
19
20 envdata.setVar(cmd_func, 'exec ' + command)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050021 envdata.setVarFlag(cmd_func, 'func', '1')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023 runfmt = d.getVar('BB_RUNFMT') or "run.{func}.{pid}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024 runfile = runfmt.format(func=cmd_func, task=cmd_func, taskfunc=cmd_func, pid=os.getpid())
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025 runfile = os.path.join(d.getVar('T'), runfile)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026 bb.utils.mkdirhier(os.path.dirname(runfile))
27
28 with open(runfile, 'w') as script:
Brad Bishop19323692019-04-05 15:28:33 -040029 script.write(bb.build.shell_trap_code())
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030 bb.data.emit_func(cmd_func, script, envdata)
31 script.write(cmd_func)
32 script.write("\n")
Patrick Williamsc0f7c042017-02-23 20:41:17 -060033 os.chmod(runfile, 0o755)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034
35 return runfile
36
37def oe_terminal(command, title, d):
38 import oe.data
39 import oe.terminal
40
41 envdata = bb.data.init()
42
43 for v in os.environ:
44 envdata.setVar(v, os.environ[v])
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050045 envdata.setVarFlag(v, 'export', '1')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050046
47 for export in oe.data.typed_value('OE_TERMINAL_EXPORTS', d):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050048 value = d.getVar(export)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049 if value is not None:
50 os.environ[export] = str(value)
51 envdata.setVar(export, str(value))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050052 envdata.setVarFlag(export, 'export', '1')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053 if export == "PSEUDO_DISABLED":
54 if "PSEUDO_UNLOAD" in os.environ:
55 del os.environ["PSEUDO_UNLOAD"]
56 envdata.delVar("PSEUDO_UNLOAD")
57
58 # Add in all variables from the user's original environment which
59 # haven't subsequntly been set/changed
60 origbbenv = d.getVar("BB_ORIGENV", False) or {}
61 for key in origbbenv:
62 if key in envdata:
63 continue
Brad Bishop6e60e8b2018-02-01 10:27:11 -050064 value = origbbenv.getVar(key)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050065 if value is not None:
66 os.environ[key] = str(value)
67 envdata.setVar(key, str(value))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050068 envdata.setVarFlag(key, 'export', '1')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050069
Brad Bishop6e60e8b2018-02-01 10:27:11 -050070 # Use original PATH as a fallback
71 path = d.getVar('PATH') + ":" + origbbenv.getVar('PATH')
72 os.environ['PATH'] = path
73 envdata.setVar('PATH', path)
74
Patrick Williamsc124f4f2015-09-15 14:41:29 -050075 # A complex PS1 might need more escaping of chars.
76 # Lets not export PS1 instead.
77 envdata.delVar("PS1")
78
79 # Replace command with an executable wrapper script
80 command = emit_terminal_func(command, envdata, d)
81
82 terminal = oe.data.typed_value('OE_TERMINAL', d).lower()
83 if terminal == 'none':
84 bb.fatal('Devshell usage disabled with OE_TERMINAL')
85 elif terminal != 'auto':
86 try:
87 oe.terminal.spawn(terminal, command, title, None, d)
88 return
89 except oe.terminal.UnsupportedTerminal:
90 bb.warn('Unsupported terminal "%s", defaulting to "auto"' %
91 terminal)
92 except oe.terminal.ExecutionError as exc:
93 bb.fatal('Unable to spawn terminal %s: %s' % (terminal, exc))
94
95 try:
96 oe.terminal.spawn_preferred(command, title, None, d)
Brad Bishop6e60e8b2018-02-01 10:27:11 -050097 except oe.terminal.NoSupportedTerminals as nosup:
98 nosup.terms.remove("false")
99 cmds = '\n\t'.join(nosup.terms).replace("{command}",
100 "do_terminal").replace("{title}", title)
101 bb.fatal('No valid terminal found, unable to open devshell.\n' +
102 'Tried the following commands:\n\t%s' % cmds)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500103 except oe.terminal.ExecutionError as exc:
104 bb.fatal('Unable to spawn terminal %s: %s' % (terminal, exc))
105
106oe_terminal[vardepsexclude] = "BB_ORIGENV"