blob: f4033f7c2748776db3a8923ba49fc19b4da7e9bb [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "ltrace intercepts and records dynamic library calls"
2
3DESCRIPTION = "ltrace intercepts and records dynamic library calls \
4which are called by an executed process and the signals received by that process. \
5It can also intercept and print the system calls executed by the program.\
6"
7HOMEPAGE = "http://ltrace.org/"
8
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
11
12PE = "1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013PV = "7.91+git${SRCPV}"
14SRCREV = "c22d359433b333937ee3d803450dc41998115685"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050015
16DEPENDS = "elfutils"
17RDEPENDS_${PN} = "elfutils"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018SRC_URI = "git://github.com/sparkleholic/ltrace.git;branch=master;protocol=http \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019 file://configure-allow-to-disable-selinux-support.patch \
Patrick Williamsddad1a12017-02-23 20:36:32 -060020 file://0001-replace-readdir_r-with-readdir.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021 file://0001-Use-correct-enum-type.patch \
22 file://0002-Fix-const-qualifier-error.patch \
23 file://0001-ARM-code-has-unreachable-code-after-switch-statement.patch \
24 file://0001-Fix-tautological-compare-warning.patch \
25 file://0001-Add-support-for-mips64-n32-n64.patch \
26 file://0001-configure-Recognise-linux-musl-as-a-host-OS.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050027 file://0001-mips-plt.c-Delete-include-error.h.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050029S = "${WORKDIR}/git"
30
31inherit autotools
32
Brad Bishop6e60e8b2018-02-01 10:27:11 -050033PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050034PACKAGECONFIG[unwind] = "--with-libunwind,--without-libunwind,libunwind"
35PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
36
37do_configure_prepend () {
Patrick Williamsddad1a12017-02-23 20:36:32 -060038 ( cd ${S}; ./autogen.sh )
Patrick Williamsb48b7b42016-08-17 15:04:38 -050039}