blob: 21a86de39007ec5a5fef356d4e4844e1fc5c193f [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4DEPENDS = "libusb-compat libftdi"
5RDEPENDS_${PN} = "libusb1"
6
Brad Bishop757e94a2018-09-07 18:58:51 +00007SRC_URI = " \
8 git://repo.or.cz/openocd.git;protocol=http;name=openocd \
9 git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \
10 git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \
11 git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012 file://0001-Fix-libusb-1.0.22-deprecated-libusb_set_debug-with-l.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
Brad Bishop757e94a2018-09-07 18:58:51 +000015SRCREV_FORMAT = "openocd"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016SRCREV_openocd = "cdf1e826eb23c29de1019ce64125f644f01b0afe"
Brad Bishop757e94a2018-09-07 18:58:51 +000017SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba"
18SRCREV_jimtcl = "a9bf5975fd0f89974d689a2d9ebd0873c8d64787"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019SRCREV_libjaylink = "8645845c1abebd004e991ba9a7f808f4fd0c608b"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020
21PV = "0.10+gitr${SRCPV}"
22S = "${WORKDIR}/git"
23
24inherit pkgconfig autotools-brokensep gettext
25
26BBCLASSEXTEND += "nativesdk"
27
Brad Bishop757e94a2018-09-07 18:58:51 +000028EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050029
30do_configure() {
Brad Bishop757e94a2018-09-07 18:58:51 +000031 ./bootstrap nosubmodule
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032 oe_runconf ${EXTRA_OECONF}
33}
34
35do_install() {
36 oe_runmake DESTDIR=${D} install
37 if [ -e "${D}${infodir}" ]; then
38 rm -Rf ${D}${infodir}
39 fi
40 if [ -e "${D}${mandir}" ]; then
41 rm -Rf ${D}${mandir}
42 fi
43 if [ -e "${D}${bindir}/.debug" ]; then
44 rm -Rf ${D}${bindir}/.debug
45 fi
46}
47
48FILES_${PN} = " \
49 ${datadir}/openocd/* \
50 ${bindir}/openocd \
51 "
52
53PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio"
54PACKAGECONFIG ??= "sysfsgpio"