blob: 4bf0ac04577f1bc9ea33c98c5c1570965c86989f [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2007 OpenedHand Ltd
3#
4
5SUMMARY = "Host packages for the standalone SDK or external toolchain"
6PR = "r12"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
8inherit packagegroup nativesdk
9
10PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
11
12RDEPENDS_${PN} = "\
13 nativesdk-pkgconfig \
14 nativesdk-qemu \
15 nativesdk-qemu-helper \
16 nativesdk-pseudo \
17 nativesdk-unfs3 \
18 nativesdk-opkg \
19 nativesdk-libtool \
20 nativesdk-autoconf \
21 nativesdk-automake \
22 nativesdk-shadow \
23 nativesdk-makedevs \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024 nativesdk-cmake \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060025 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'nativesdk-wayland', '', d)} \
Brad Bishop316dfdd2018-06-25 12:45:53 -040026 nativesdk-sdk-provides-dummy \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027 nativesdk-bison \
28 nativesdk-flex \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029 "
30
31RDEPENDS_${PN}_darwin = "\
32 nativesdk-pkgconfig \
33 nativesdk-opkg \
34 nativesdk-libtool \
35 "