blob: 2f412634571a24102c7f16f4ebda27bd8cfeb6aa [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Note, we can probably remove the lzma option as it has be replaced with xz,
2# and I don't think the kernel supports it any more.
3SUMMARY = "Tools for manipulating SquashFS filesystems"
4SECTION = "base"
5LICENSE = "GPL-2 & PD"
6LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://../../7zC.txt;beginline=12;endline=16;md5=2056cd6d919ebc3807602143c7449a7c \
8"
9DEPENDS = "attr zlib xz lzo lz4"
10
11PV = "4.3+gitr${SRCPV}"
12SRCREV = "9c1db6d13a51a2e009f0027ef336ce03624eac0d"
13SRC_URI = "git://github.com/plougher/squashfs-tools.git;protocol=https \
14 http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2;name=lzma \
Patrick Williamsd7e96312015-09-22 08:09:05 -050015 file://0001-mksquashfs.c-get-inline-functions-work-with-C99.patch;striplevel=2 \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016 file://squashfs-tools-4.3-sysmacros.patch;striplevel=2 \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050017 file://fix-compat.patch \
Brad Bishopbba38f32018-08-23 16:11:46 +080018 file://0001-squashfs-tools-patch-for-CVE-2015-4645-6.patch;striplevel=2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019"
Brad Bishop316dfdd2018-06-25 12:45:53 -040020UPSTREAM_CHECK_COMMITS = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759"
22SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e"
23
24S = "${WORKDIR}/git/squashfs-tools"
25
26# EXTRA_OEMAKE is typically: -e MAKEFLAGS=
27# the -e causes problems as CFLAGS is modified in the Makefile, so
28# we redefine EXTRA_OEMAKE here
29EXTRA_OEMAKE = "MAKEFLAGS= LZMA_SUPPORT=1 LZMA_DIR=../.. XZ_SUPPORT=1 LZO_SUPPORT=1 LZ4_SUPPORT=1"
30
31do_compile() {
32 oe_runmake mksquashfs unsquashfs
33}
34do_install () {
35 install -d ${D}${sbindir}
36 install -m 0755 mksquashfs ${D}${sbindir}/
37 install -m 0755 unsquashfs ${D}${sbindir}/
38}
39
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080040ARM_INSTRUCTION_SET_armv4 = "arm"
41ARM_INSTRUCTION_SET_armv5 = "arm"
42ARM_INSTRUCTION_SET_armv6 = "arm"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043
44BBCLASSEXTEND = "native nativesdk"