blob: bae4948751591bedfb41b9fb3eb665eab587739f [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Performance analysis tools for Linux"
2DESCRIPTION = "Performance counters for Linux are a new kernel-based \
3subsystem that provide a framework for all things \
4performance analysis. It covers hardware level \
5(CPU/PMU, Performance Monitoring Unit) features \
6and software features (software counters, tracepoints) \
7as well."
Joel Stanleye252c312017-12-14 15:11:12 +10308HOMEPAGE = "https://perf.wiki.kernel.org/index.php/Main_Page"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
10LICENSE = "GPLv2"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
12PR = "r9"
13
Joel Stanleye252c312017-12-14 15:11:12 +103014PACKAGECONFIG ??= "scripting tui libunwind"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015PACKAGECONFIG[dwarf] = ",NO_DWARF=1"
Joel Stanleye252c312017-12-14 15:11:12 +103016PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017# gui support was added with kernel 3.6.35
18# since 3.10 libnewt was replaced by slang
19# to cover a wide range of kernel we add both dependencies
Joel Stanleye252c312017-12-14 15:11:12 +103020PACKAGECONFIG[tui] = ",NO_NEWT=1,libnewt slang"
21PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind"
22PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1"
23PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap"
24PACKAGECONFIG[jvmti] = ",NO_JVMTI=1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040025# libaudit support would need scripting to be enabled
26PACKAGECONFIG[audit] = ",NO_LIBAUDIT=1,audit"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027PACKAGECONFIG[manpages] = ",,xmlto-native asciidoc-native"
28
29# libunwind is not yet ported for some architectures
30PACKAGECONFIG_remove_arc = "libunwind"
31PACKAGECONFIG_remove_riscv64 = "libunwind"
Brad Bishop316dfdd2018-06-25 12:45:53 -040032
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033DEPENDS = " \
34 virtual/${MLPREFIX}libc \
35 ${MLPREFIX}elfutils \
36 ${MLPREFIX}binutils \
Brad Bishop316dfdd2018-06-25 12:45:53 -040037 bison-native flex-native xz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050038"
39
40do_configure[depends] += "virtual/kernel:do_shared_workdir"
41
42PROVIDES = "virtual/perf"
43
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080044inherit linux-kernel-base kernel-arch manpages
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045
46# needed for building the tools/perf Python bindings
Brad Bishop316dfdd2018-06-25 12:45:53 -040047inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'pythonnative', '', d)}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048inherit python-dir
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049export PYTHON_SITEPACKAGES_DIR
50
51#kernel 3.1+ supports WERROR to disable warnings as errors
52export WERROR = "0"
53
54do_populate_lic[depends] += "virtual/kernel:do_patch"
55
56# needed for building the tools/perf Perl binding
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080057include ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'perf-perl.inc', '', d)}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050058
59inherit kernelsrc
60
Brad Bishop316dfdd2018-06-25 12:45:53 -040061S = "${WORKDIR}/${BP}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062SPDX_S = "${S}/tools/perf"
63
Patrick Williamsc124f4f2015-09-15 14:41:29 -050064# The LDFLAGS is required or some old kernels fails due missing
65# symbols and this is preferred than requiring patches to every old
66# supported kernel.
67LDFLAGS="-ldl -lutil"
68
69EXTRA_OEMAKE = '\
70 -C ${S}/tools/perf \
71 O=${B} \
72 CROSS_COMPILE=${TARGET_PREFIX} \
73 ARCH=${ARCH} \
74 CC="${CC}" \
75 AR="${AR}" \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060076 LD="${LD}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050077 EXTRA_CFLAGS="-ldw" \
Joel Stanleye252c312017-12-14 15:11:12 +103078 EXTRA_LDFLAGS="${PERF_EXTRA_LDFLAGS}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050079 perfexecdir=${libexecdir} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080080 NO_GTK2=1 \
Joel Stanleye252c312017-12-14 15:11:12 +103081 ${PACKAGECONFIG_CONFARGS} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080082 TMPDIR="${B}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050083'
84
85EXTRA_OEMAKE += "\
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050086 'DESTDIR=${D}' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050087 'prefix=${prefix}' \
88 'bindir=${bindir}' \
89 'sharedir=${datadir}' \
90 'sysconfdir=${sysconfdir}' \
91 'perfexecdir=${libexecdir}/perf-core' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050092 'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \
93 'sharedir=${@os.path.relpath(datadir, prefix)}' \
94 'mandir=${@os.path.relpath(mandir, prefix)}' \
95 'infodir=${@os.path.relpath(infodir, prefix)}' \
96"
97
Brad Bishopd5ae7d92018-06-14 09:52:03 -070098# During do_configure, we might run a 'make clean'. That often breaks
99# when done in parallel, so disable parallelism for do_configure. Note
100# that it has to be done this way rather than by passing -j1, since
101# perf's build system by default ignores any -j argument, but does
102# honour a JOBS variable.
103EXTRA_OEMAKE_append_task-configure = " JOBS=1"
104
Brad Bishop316dfdd2018-06-25 12:45:53 -0400105PERF_SRC ?= "Makefile \
106 include \
107 tools/arch \
108 tools/build \
109 tools/include \
110 tools/lib \
111 tools/Makefile \
112 tools/perf \
113 tools/scripts \
114"
115
Joel Stanleye252c312017-12-14 15:11:12 +1030116PERF_EXTRA_LDFLAGS = ""
117
118# MIPS N32
119PERF_EXTRA_LDFLAGS_mipsarchn32eb = "-m elf32btsmipn32"
120PERF_EXTRA_LDFLAGS_mipsarchn32el = "-m elf32ltsmipn32"
121
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500122do_compile() {
123 # Linux kernel build system is expected to do the right thing
124 unset CFLAGS
125 oe_runmake all
126}
127
128do_install() {
129 # Linux kernel build system is expected to do the right thing
130 unset CFLAGS
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500131 oe_runmake install
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500132 # we are checking for this make target to be compatible with older perf versions
Joel Stanleye252c312017-12-14 15:11:12 +1030133 if ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'true', 'false', d)} && grep -q install-python_ext ${S}/tools/perf/Makefile*; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500134 oe_runmake DESTDIR=${D} install-python_ext
135 fi
136}
137
Brad Bishop316dfdd2018-06-25 12:45:53 -0400138do_configure[prefuncs] += "copy_perf_source_from_kernel"
139python copy_perf_source_from_kernel() {
140 sources = (d.getVar("PERF_SRC") or "").split()
141 src_dir = d.getVar("STAGING_KERNEL_DIR")
142 dest_dir = d.getVar("S")
143 bb.utils.mkdirhier(dest_dir)
144 for s in sources:
145 src = oe.path.join(src_dir, s)
146 dest = oe.path.join(dest_dir, s)
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800147 if not os.path.exists(src):
148 bb.fatal("Path does not exist: %s. Maybe PERF_SRC does not match the kernel version." % src)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400149 if os.path.isdir(src):
150 oe.path.copyhardlinktree(src, dest)
151 else:
152 bb.utils.copyfile(src, dest)
153}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500154
Brad Bishop316dfdd2018-06-25 12:45:53 -0400155do_configure_prepend () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500156 # If building a multlib based perf, the incorrect library path will be
157 # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit
158 # build, with a 64 bit multilib, the arch won't match and the detection of a
159 # 64 bit build (and library) are not exected. To ensure that libraries are
160 # installed to the correct location, we can use the weak assignment in the
161 # config/Makefile.
162 #
163 # Also need to relocate .config-detected to $(OUTPUT)/config-detected
164 # for kernel sources that do not already do this
165 # as two builds (e.g. perf and lib32-perf from mutlilib can conflict
166 # with each other if its in the shared source directory
167 #
168 if [ -e "${S}/tools/perf/config/Makefile" ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600169 perfconfig="${S}/tools/perf/config/Makefile"
170 fi
171 if [ -e "${S}/tools/perf/Makefile.config" ]; then
172 perfconfig="${S}/tools/perf/Makefile.config"
173 fi
174 if [ -n "${perfconfig}" ]; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500175 # Match $(prefix)/$(lib) and $(prefix)/lib
176 sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
177 -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \
178 -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600179 ${perfconfig}
180 fi
181 # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)"
182 # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it
183 # will use the relative path 'share/man', in the way it will resulting in
184 # incorrect installation for man pages.
185 if [ -e "${S}/tools/perf/Documentation/Makefile" ]; then
186 sed -i 's,^mandir?=,mandir:=,' ${S}/tools/perf/Documentation/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500187 fi
188 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
189 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
190 ${S}/tools/perf/Makefile.perf
191 sed -i -e "s,prefix='\$(DESTDIR_SQ)/usr'$,prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
192 ${S}/tools/perf/Makefile.perf
193 fi
194 sed -i -e "s,--root='/\$(DESTDIR_SQ)',--prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
Patrick Williamsd7e96312015-09-22 08:09:05 -0500195 ${S}/tools/perf/Makefile*
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500196
197 if [ -e "${S}/tools/build/Makefile.build" ]; then
198 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
199 ${S}/tools/build/Makefile.build
200 fi
201
202 # We need to ensure the --sysroot option in CC is preserved
203 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
204 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/perf/Makefile.perf
205 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600206 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500207 fi
208 if [ -e "${S}/tools/lib/api/Makefile" ]; then
209 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/api/Makefile
210 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/api/Makefile
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600211 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/lib/api/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500212 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500213 if [ -e "${S}/tools/lib/subcmd/Makefile" ]; then
214 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/subcmd/Makefile
215 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/subcmd/Makefile
216 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500217 if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
218 sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
219 fi
220 if [ -e "${S}/tools/build/Makefile.feature" ]; then
221 sed -i 's,CFLAGS=,CC="\$(CC)" CFLAGS=,' ${S}/tools/build/Makefile.feature
222 fi
223
224 # 3.17-rc1+ has a include issue for arm/powerpc. Temporarily sed in the appropriate include
225 if [ -e "${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c" ]; then
226 sed -i 's,#include "util/callchain.h",#include "util/callchain.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c
227 fi
228 if [ -e "${S}/tools/perf/arch/arm/util/unwind-libunwind.c" ] && [ -e "${S}/tools/perf/arch/arm/tests/dwarf-unwind.c" ]; then
229 sed -i 's,#include "tests/tests.h",#include "tests/tests.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/tests/dwarf-unwind.c
230 sed -i 's,#include "perf_regs.h",#include "perf_regs.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/util/unwind-libunwind.c
231 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500232
233 # use /usr/bin/env instead of version specific python
234 for s in `find ${S}/tools/perf/scripts/python/ -name '*.py'`; do
235 sed -i 's,/usr/bin/python2,/usr/bin/env python,' "${s}"
236 done
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500237}
238
239python do_package_prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500240 d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500241}
242
243PACKAGE_ARCH = "${MACHINE_ARCH}"
244
245
246PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
247
248RDEPENDS_${PN} += "elfutils bash"
249RDEPENDS_${PN}-archive =+ "bash"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400250RDEPENDS_${PN}-python =+ "bash python python-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python', '', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500251RDEPENDS_${PN}-perl =+ "bash perl perl-modules"
252RDEPENDS_${PN}-tests =+ "python"
253
Joel Stanleye252c312017-12-14 15:11:12 +1030254RSUGGESTS_SCRIPTING = "${@bb.utils.contains('PACKAGECONFIG', 'scripting', '${PN}-perl ${PN}-python', '',d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500255RSUGGESTS_${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}"
256
257FILES_${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500258FILES_${PN}-archive = "${libdir}/perf/perf-core/perf-archive"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500259FILES_${PN}-tests = "${libdir}/perf/perf-core/tests ${libexecdir}/perf-core/tests"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400260FILES_${PN}-python = " \
261 ${PYTHON_SITEPACKAGES_DIR} \
262 ${libexecdir}/perf-core/scripts/python \
263 "
264FILES_${PN}-perl = "${libexecdir}/perf-core/scripts/perl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500265
266
267INHIBIT_PACKAGE_DEBUG_SPLIT="1"