blob: 24192d7ab4c0f9100e536b5148bbc9de6226f2fa [file] [log] [blame]
Patrick Williams9e206392017-01-19 21:20:46 -06001SUMMARY = "Phosphor State Management"
2DESCRIPTION = "Phosphor State Manager provides a set of system state \
3management daemons. It is suitable for use on a wide variety of OpenBMC \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10STATE_MGR_PACKAGES = " \
11 ${PN}-host \
12 ${PN}-chassis \
Josh Kingd2b95c72017-01-19 14:04:03 -060013 ${PN}-bmc \
Patrick Williams9e206392017-01-19 21:20:46 -060014"
15PACKAGES =+ "${STATE_MGR_PACKAGES}"
Brad Bishop1a5a5972017-03-01 16:08:45 -050016PACKAGES_remove = "${PN}"
17RDEPENDS_${PN}-dev = "${STATE_MGR_PACKAGES}"
18RDEPENDS_${PN}-staticdev = "${STATE_MGR_PACKAGES}"
19
Patrick Williams9e206392017-01-19 21:20:46 -060020DBUS_PACKAGES = "${STATE_MGR_PACKAGES}"
21
22# Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES
23# handles the rest.
24SYSTEMD_PACKAGES = ""
25
26inherit autotools pkgconfig
27inherit obmc-phosphor-dbus-service
28
29DEPENDS += "autoconf-archive-native"
30DEPENDS += "sdbusplus"
31DEPENDS += "phosphor-logging"
Patrick Williams1815f6b2017-01-30 11:06:16 -060032DEPENDS += "phosphor-dbus-interfaces"
Adriana Kobylak86354212017-01-30 20:30:00 -060033RDEPENDS_${PN} += "sdbusplus"
Patrick Williams9e206392017-01-19 21:20:46 -060034
Patrick Williams1815f6b2017-01-30 11:06:16 -060035RDEPENDS_${PN}-host += "libsystemd phosphor-dbus-interfaces"
36RDEPENDS_${PN}-chassis += "libsystemd phosphor-dbus-interfaces"
37RDEPENDS_${PN}-bmc += "libsystemd phosphor-dbus-interfaces"
Patrick Williams9e206392017-01-19 21:20:46 -060038
39PROVIDES += "virtual/obmc-host-state-mgmt"
40RPROVIDES_${PN}-host += "virtual-obmc-host-state-mgmt"
41FILES_${PN}-host = "${sbindir}/phosphor-host-state-manager"
42DBUS_SERVICE_${PN}-host += "xyz.openbmc_project.State.Host.service"
43
44PROVIDES += "virtual/obmc-chassis-state-mgmt"
45RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-state-mgmt"
46FILES_${PN}-chassis = "${sbindir}/phosphor-chassis-state-manager"
47DBUS_SERVICE_${PN}-chassis += "xyz.openbmc_project.State.Chassis.service"
48
Josh Kingd2b95c72017-01-19 14:04:03 -060049PROVIDES += "virtual/obmc-bmc-state-mgmt"
50RPROVIDES_${PN}-bmc += "virtual-obmc-bmc-state-mgmt"
51FILES_${PN}-bmc = "${sbindir}/phosphor-bmc-state-manager"
52DBUS_SERVICE_${PN}-bmc += "xyz.openbmc_project.State.BMC.service"
53
Patrick Williams9e206392017-01-19 21:20:46 -060054SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
Patrick Williams5d5e6792017-02-24 10:00:04 -060055SRCREV = "adaa721742d565aaf6a00cdaa25db745aa6993d5"
Patrick Williams9e206392017-01-19 21:20:46 -060056
57S = "${WORKDIR}/git"