blob: f06a8d28f88135f4d89d4a9eca52cef8132d85c4 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Library to handle input devices in Wayland compositors"
Brad Bishop1d80a2e2019-11-15 16:35:03 -05002DESCRIPTION = "libinput is a library to handle input devices in Wayland \
3compositors and to provide a generic X.Org input driver. It provides \
4device detection, device handling, input device event processing and \
5abstraction so minimize the amount of custom input code compositors need to \
6provide the common set of functionality that users expect."
Brad Bishopc342db32019-05-15 21:57:59 -04007HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
8SECTION = "libs"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://COPYING;md5=1f2ea9ebff3a2c6d458faf58492efb63"
12
13DEPENDS = "libevdev udev mtdev"
14
15SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz"
Brad Bishop1d80a2e2019-11-15 16:35:03 -050016SRC_URI[md5sum] = "d052faa64eb6d2e649e582cc0fcf6e32"
17SRC_URI[sha256sum] = "0feb3a0589709cc1032893bfaf4c49150d5360bd9782bec888f9e4dd9044c5b7"
Brad Bishopc342db32019-05-15 21:57:59 -040018
19UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
20
21inherit meson pkgconfig lib_package
22
23PACKAGECONFIG ??= ""
24PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom"
25PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3"
26
27UDEVDIR = "`pkg-config --variable=udevdir udev`"
28
Brad Bishopa34c0302019-09-23 22:34:48 -040029EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \
30 -Ddocumentation=false \
31 -Dtests=false \
32 -Dzshcompletiondir=no"
Brad Bishopc342db32019-05-15 21:57:59 -040033
34# package name changed in 1.8.1 upgrade: make sure package upgrades work
35RPROVIDES_${PN} = "libinput"
36RREPLACES_${PN} = "libinput"
37RCONFLICTS_${PN} = "libinput"