blob: 5ac18ba3f1a307faf18712a2b2880561671791b3 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "A complete, cross-platform solution to record, convert and stream audio and video."
2DESCRIPTION = "FFmpeg is the leading multimedia framework, able to decode, encode, transcode, \
3 mux, demux, stream, filter and play pretty much anything that humans and machines \
4 have created. It supports the most obscure ancient formats up to the cutting edge."
5HOMEPAGE = "https://www.ffmpeg.org/"
6SECTION = "libs"
7
8LICENSE = "BSD & GPLv2+ & LGPLv2.1+ & MIT"
9LICENSE_${PN} = "GPLv2+"
10LICENSE_libavcodec = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
11LICENSE_libavdevice = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
12LICENSE_libavfilter = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
13LICENSE_libavformat = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
14LICENSE_libavresample = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
15LICENSE_libavutil = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
16LICENSE_libpostproc = "GPLv2+"
17LICENSE_libswresample = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
18LICENSE_libswscale = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
19LICENSE_FLAGS = "commercial"
20
21LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
22 file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
23 file://COPYING.LGPLv2.1;md5=bd7a443320af8c812e4c18d1b79df004 \
24 file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02"
25
26SRC_URI = "https://www.ffmpeg.org/releases/${BP}.tar.xz \
27 file://mips64_cpu_detection.patch \
28 "
Brad Bishop00e122a2019-10-05 11:10:57 -040029SRC_URI[md5sum] = "67da904cf9fddeeb10a1308fc0dc39de"
30SRC_URI[sha256sum] = "cec7c87e9b60d174509e263ac4011b522385fd0775292e1670ecc1180c9bb6d4"
Brad Bishopc342db32019-05-15 21:57:59 -040031
32# Build fails when thumb is enabled: https://bugzilla.yoctoproject.org/show_bug.cgi?id=7717
33ARM_INSTRUCTION_SET_armv4 = "arm"
34ARM_INSTRUCTION_SET_armv5 = "arm"
35ARM_INSTRUCTION_SET_armv6 = "arm"
36
37# Should be API compatible with libav (which was a fork of ffmpeg)
38# libpostproc was previously packaged from a separate recipe
39PROVIDES = "libav libpostproc"
40
Brad Bishopa34c0302019-09-23 22:34:48 -040041DEPENDS = "nasm-native"
Brad Bishopc342db32019-05-15 21:57:59 -040042
43inherit autotools pkgconfig
44
45PACKAGECONFIG ??= "avdevice avfilter avcodec avformat swresample swscale postproc avresample \
Brad Bishopa34c0302019-09-23 22:34:48 -040046 alsa bzlib gpl lzma theora x264 zlib \
Brad Bishop96ff1982019-08-19 13:50:42 -040047 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xv xcb', '', d)}"
Brad Bishopc342db32019-05-15 21:57:59 -040048
49# libraries to build in addition to avutil
50PACKAGECONFIG[avdevice] = "--enable-avdevice,--disable-avdevice"
51PACKAGECONFIG[avfilter] = "--enable-avfilter,--disable-avfilter"
52PACKAGECONFIG[avcodec] = "--enable-avcodec,--disable-avcodec"
53PACKAGECONFIG[avformat] = "--enable-avformat,--disable-avformat"
54PACKAGECONFIG[swresample] = "--enable-swresample,--disable-swresample"
55PACKAGECONFIG[swscale] = "--enable-swscale,--disable-swscale"
56PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc"
57PACKAGECONFIG[avresample] = "--enable-avresample,--disable-avresample"
58
59# features to support
Brad Bishopa34c0302019-09-23 22:34:48 -040060PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
Brad Bishopc342db32019-05-15 21:57:59 -040061PACKAGECONFIG[bzlib] = "--enable-bzlib,--disable-bzlib,bzip2"
62PACKAGECONFIG[gpl] = "--enable-gpl,--disable-gpl"
63PACKAGECONFIG[gsm] = "--enable-libgsm,--disable-libgsm,libgsm"
64PACKAGECONFIG[jack] = "--enable-indev=jack,--disable-indev=jack,jack"
65PACKAGECONFIG[libvorbis] = "--enable-libvorbis,--disable-libvorbis,libvorbis"
66PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz"
Brad Bishop15ae2502019-06-18 21:44:24 -040067PACKAGECONFIG[mfx] = "--enable-libmfx,--disable-libmfx,intel-mediasdk"
Brad Bishopc342db32019-05-15 21:57:59 -040068PACKAGECONFIG[mp3lame] = "--enable-libmp3lame,--disable-libmp3lame,lame"
69PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
70PACKAGECONFIG[sdl2] = "--enable-sdl2,--disable-sdl2,virtual/libsdl2"
71PACKAGECONFIG[speex] = "--enable-libspeex,--disable-libspeex,speex"
Brad Bishopa34c0302019-09-23 22:34:48 -040072PACKAGECONFIG[theora] = "--enable-libtheora,--disable-libtheora,libtheora libogg"
Brad Bishopc342db32019-05-15 21:57:59 -040073PACKAGECONFIG[vaapi] = "--enable-vaapi,--disable-vaapi,libva"
74PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau"
75PACKAGECONFIG[vpx] = "--enable-libvpx,--disable-libvpx,libvpx"
76PACKAGECONFIG[x264] = "--enable-libx264,--disable-libx264,x264"
Brad Bishop96ff1982019-08-19 13:50:42 -040077PACKAGECONFIG[xcb] = "--enable-libxcb,--disable-libxcb,libxcb"
Brad Bishopc342db32019-05-15 21:57:59 -040078PACKAGECONFIG[xv] = "--enable-outdev=xv,--disable-outdev=xv,libxv"
Brad Bishopa34c0302019-09-23 22:34:48 -040079PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
Brad Bishopc342db32019-05-15 21:57:59 -040080
81# Check codecs that require --enable-nonfree
82USE_NONFREE = "${@bb.utils.contains_any('PACKAGECONFIG', [ 'openssl' ], 'yes', '', d)}"
83
84def cpu(d):
85 for arg in (d.getVar('TUNE_CCARGS') or '').split():
86 if arg.startswith('-mcpu='):
87 return arg[6:]
88 return 'generic'
89
90EXTRA_OECONF = " \
91 --disable-stripping \
92 --enable-pic \
93 --enable-shared \
94 --enable-pthreads \
Brad Bishopc342db32019-05-15 21:57:59 -040095 ${@bb.utils.contains('USE_NONFREE', 'yes', '--enable-nonfree', '', d)} \
96 \
97 --cross-prefix=${TARGET_PREFIX} \
98 \
99 --ld="${CCLD}" \
100 --cc="${CC}" \
101 --cxx="${CXX}" \
102 --arch=${TARGET_ARCH} \
103 --target-os="linux" \
104 --enable-cross-compile \
Brad Bishop1d80a2e2019-11-15 16:35:03 -0500105 --extra-cflags="${CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
106 --extra-ldflags="${LDFLAGS}" \
Brad Bishopc342db32019-05-15 21:57:59 -0400107 --sysroot="${STAGING_DIR_TARGET}" \
Brad Bishopc342db32019-05-15 21:57:59 -0400108 ${EXTRA_FFCONF} \
109 --libdir=${libdir} \
110 --shlibdir=${libdir} \
111 --datadir=${datadir}/ffmpeg \
112 ${@bb.utils.contains('AVAILTUNES', 'mips32r2', '', '--disable-mipsdsp --disable-mipsdspr2', d)} \
113 --cpu=${@cpu(d)} \
114 --pkg-config=pkg-config \
115"
116
117EXTRA_OECONF_append_linux-gnux32 = " --disable-asm"
118# gold crashes on x86, another solution is to --disable-asm but thats more hacky
119# ld.gold: internal error in relocate_section, at ../../gold/i386.cc:3684
120
121LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
122
Brad Bishop00e122a2019-10-05 11:10:57 -0400123EXTRA_OEMAKE = "V=1"
124
Brad Bishopc342db32019-05-15 21:57:59 -0400125do_configure() {
126 ${S}/configure ${EXTRA_OECONF}
127}
128
129PACKAGES =+ "libavcodec \
130 libavdevice \
131 libavfilter \
132 libavformat \
133 libavresample \
134 libavutil \
135 libpostproc \
136 libswresample \
137 libswscale"
138
139FILES_libavcodec = "${libdir}/libavcodec${SOLIBS}"
140FILES_libavdevice = "${libdir}/libavdevice${SOLIBS}"
141FILES_libavfilter = "${libdir}/libavfilter${SOLIBS}"
142FILES_libavformat = "${libdir}/libavformat${SOLIBS}"
143FILES_libavresample = "${libdir}/libavresample${SOLIBS}"
144FILES_libavutil = "${libdir}/libavutil${SOLIBS}"
145FILES_libpostproc = "${libdir}/libpostproc${SOLIBS}"
146FILES_libswresample = "${libdir}/libswresample${SOLIBS}"
147FILES_libswscale = "${libdir}/libswscale${SOLIBS}"
148
149# ffmpeg disables PIC on some platforms (e.g. x86-32)
150INSANE_SKIP_${MLPREFIX}libavcodec = "textrel"
151INSANE_SKIP_${MLPREFIX}libavdevice = "textrel"
152INSANE_SKIP_${MLPREFIX}libavfilter = "textrel"
153INSANE_SKIP_${MLPREFIX}libavformat = "textrel"
154INSANE_SKIP_${MLPREFIX}libavutil = "textrel"
155INSANE_SKIP_${MLPREFIX}libavresample = "textrel"
156INSANE_SKIP_${MLPREFIX}libswscale = "textrel"
157INSANE_SKIP_${MLPREFIX}libswresample = "textrel"
158INSANE_SKIP_${MLPREFIX}libpostproc = "textrel"