blob: bb8885f1c817e7203a197cf716f3b0e34896c45b [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)"
2HOMEPAGE = "http://www.gnupg.org/"
3LICENSE = "GPLv3 & LGPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \
5 file://COPYING.LGPL3;md5=a2b6bf2cb38ee52619e60f30a1fc7257"
6
7DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt"
8
9inherit autotools gettext texinfo pkgconfig
10
11UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
12SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://0001-Use-pkg-config-to-find-pth-instead-of-pth-config.patch \
14 file://0002-use-pkgconfig-instead-of-npth-config.patch \
15 file://0003-dirmngr-uses-libgpg-error.patch \
16 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \
17 file://0001-Woverride-init-is-not-needed-with-gcc-9.patch \
18 "
19SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \
20 file://relocate.patch"
21
Brad Bishop96ff1982019-08-19 13:50:42 -040022SRC_URI[md5sum] = "1ba2d9b70c377f8e967742064c27a19c"
23SRC_URI[sha256sum] = "afa262868e39b651a2db4c071fba90415154243e83a830ca00516f9a807fd514"
Brad Bishopc342db32019-05-15 21:57:59 -040024
25EXTRA_OECONF = "--disable-ldap \
26 --disable-ccid-driver \
27 --with-zlib=${STAGING_LIBDIR}/.. \
28 --with-bzip2=${STAGING_LIBDIR}/.. \
29 --with-readline=${STAGING_LIBDIR}/.. \
30 --enable-gpg-is-gpg2 \
31 "
Brad Bishop1d80a2e2019-11-15 16:35:03 -050032
33# A minimal package containing just enough to run gpg+gpgagent (E.g. use gpgme in opkg)
34PACKAGES =+ "${PN}-gpg"
35FILES_${PN}-gpg = " \
36 ${bindir}/gpg \
37 ${bindir}/gpg2 \
38 ${bindir}/gpg-agent \
39"
40
41# Normal package (gnupg) should depend on minimal package (gnupg-gpg)
42# to ensure all tools are included. This is done only in non-native
43# builds. Native builds don't have sub-packages, so appending RDEPENDS
44# in this case breaks recipe parsing.
45RDEPENDS_${PN} += "${@ "" if ("native" in d.getVar("PN")) else (d.getVar("PN") + "-gpg")}"
46
Brad Bishopc342db32019-05-15 21:57:59 -040047RRECOMMENDS_${PN} = "pinentry"
48
49do_configure_prepend () {
50 # Else these could be used in prefernce to those in aclocal-copy
51 rm -f ${S}/m4/gpg-error.m4
52 rm -f ${S}/m4/libassuan.m4
53 rm -f ${S}/m4/ksba.m4
54 rm -f ${S}/m4/libgcrypt.m4
55}
56
57do_install_append() {
58 ln -sf gpg2 ${D}${bindir}/gpg
59 ln -sf gpgv2 ${D}${bindir}/gpgv
60}
61
62do_install_append_class-native() {
63 create_wrapper ${D}${bindir}/gpg2 GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
Brad Bishopa34c0302019-09-23 22:34:48 -040064 create_wrapper ${D}${bindir}/gpgconf GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
65 create_wrapper ${D}${bindir}/gpg-agent GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
66 create_wrapper ${D}${bindir}/gpg-connect-agent GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
Brad Bishopc342db32019-05-15 21:57:59 -040067}
68
69PACKAGECONFIG ??= "gnutls"
70PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls"
71PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"
72
Brad Bishop1d80a2e2019-11-15 16:35:03 -050073BBCLASSEXTEND = "native nativesdk"