Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "User-space front-end command-line tool for ftrace" |
| 2 | |
| 3 | LICENSE = "GPL-2.0-only & LGPL-2.1-only" |
| 4 | LIC_FILES_CHKSUM = " \ |
| 5 | file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97 \ |
| 6 | file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd \ |
| 7 | " |
| 8 | |
| 9 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git;branch=master \ |
| 10 | file://0001-Replace-LFS64-interfaces-off64_t-and-lseek64.patch \ |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 11 | file://0002-Drop-using-_LARGEFILE64_SOURCE.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | file://0001-Do-not-emit-useless-rpath.patch" |
| 13 | SRCREV = "18233e4c32857cb7ddd4960beeec8360ed834fc5" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | DEPENDS += "libtraceevent libtracefs zstd xmlto-native asciidoc-native swig-native bison-native flex-native" |
| 18 | |
| 19 | inherit pkgconfig bash-completion |
| 20 | |
| 21 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 22 | |
| 23 | do_compile() { |
| 24 | oe_runmake libdir_relative=${BASELIB} libs |
| 25 | oe_runmake libdir_relative=${BASELIB} all |
| 26 | } |
| 27 | |
| 28 | do_install() { |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 29 | oe_runmake libdir_relative=${baselib} etcdir=${sysconfdir} pkgconfig_dir=${libdir}/pkgconfig DESTDIR=${D} install install_libs |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 30 | # Because makefile uses cp instead of install we need to change owner of files |
| 31 | chown -R root:root ${D}${libdir} |
| 32 | } |