blob: 79cb36c513e46d2e610fb2e10fcd9c7a6553c635 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001inherit package
2
3IMAGE_PKGTYPE ?= "ipk"
4
5IPKGCONF_TARGET = "${WORKDIR}/opkg.conf"
6IPKGCONF_SDK = "${WORKDIR}/opkg-sdk.conf"
7
8PKGWRITEDIRIPK = "${WORKDIR}/deploy-ipks"
9
10# Program to be used to build opkg packages
Brad Bishop19323692019-04-05 15:28:33 -040011OPKGBUILDCMD ??= 'opkg-build -Z xz -a "${XZ_DEFAULTS}"'
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050013OPKG_ARGS += "--force_postinstall --prefer-arch-to-version"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014OPKG_ARGS += "${@['', '--no-install-recommends'][d.getVar("NO_RECOMMENDATIONS") == "1"]}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015OPKG_ARGS += "${@['', '--add-exclude ' + ' --add-exclude '.join((d.getVar('PACKAGE_EXCLUDE') or "").split())][(d.getVar("PACKAGE_EXCLUDE") or "").strip() != ""]}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016
Brad Bishop96ff1982019-08-19 13:50:42 -040017OPKGLIBDIR ??= "${localstatedir}/lib"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018
19python do_package_ipk () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020 workdir = d.getVar('WORKDIR')
21 outdir = d.getVar('PKGWRITEDIRIPK')
22 tmpdir = d.getVar('TMPDIR')
23 pkgdest = d.getVar('PKGDEST')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024 if not workdir or not outdir or not tmpdir:
25 bb.error("Variables incorrectly set, unable to package")
26 return
27
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028 packages = d.getVar('PACKAGES')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029 if not packages or packages == '':
30 bb.debug(1, "No packages; nothing to do")
31 return
32
33 # We're about to add new packages so the index needs to be checked
34 # so remove the appropriate stamp file.
35 if os.access(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"), os.R_OK):
36 os.unlink(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"))
37
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038 oe.utils.multiprocess_launch(ipk_write_pkg, packages.split(), d, extraargs=(d,))
Brad Bishopd7bf8c12018-02-25 22:55:05 -050039}
40do_package_ipk[vardeps] += "ipk_write_pkg"
41do_package_ipk[vardepsexclude] = "BB_NUMBER_THREADS"
42
43def ipk_write_pkg(pkg, d):
44 import re, copy
45 import subprocess
46 import textwrap
47 import collections
Andrew Geissler82c905d2020-04-13 13:39:40 -050048 import glob
Brad Bishopd7bf8c12018-02-25 22:55:05 -050049
Patrick Williamsc124f4f2015-09-15 14:41:29 -050050 def cleanupcontrol(root):
51 for p in ['CONTROL', 'DEBIAN']:
52 p = os.path.join(root, p)
53 if os.path.exists(p):
54 bb.utils.prunedir(p)
55
Brad Bishopd7bf8c12018-02-25 22:55:05 -050056 outdir = d.getVar('PKGWRITEDIRIPK')
57 pkgdest = d.getVar('PKGDEST')
Brad Bishop6e60e8b2018-02-01 10:27:11 -050058 recipesource = os.path.basename(d.getVar('FILE'))
Brad Bishop37a0e4d2017-12-04 01:01:44 -050059
Brad Bishopd7bf8c12018-02-25 22:55:05 -050060 localdata = bb.data.createCopy(d)
61 root = "%s/%s" % (pkgdest, pkg)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062
Brad Bishopd7bf8c12018-02-25 22:55:05 -050063 lf = bb.utils.lockfile(root + ".lock")
64 try:
Patrick Williamsc124f4f2015-09-15 14:41:29 -050065 localdata.setVar('ROOT', '')
66 localdata.setVar('ROOT_%s' % pkg, root)
Brad Bishop6e60e8b2018-02-01 10:27:11 -050067 pkgname = localdata.getVar('PKG_%s' % pkg)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050068 if not pkgname:
69 pkgname = pkg
70 localdata.setVar('PKG', pkgname)
71
72 localdata.setVar('OVERRIDES', d.getVar("OVERRIDES", False) + ":" + pkg)
73
Patrick Williamsc124f4f2015-09-15 14:41:29 -050074 basedir = os.path.join(os.path.dirname(root))
Brad Bishop6e60e8b2018-02-01 10:27:11 -050075 arch = localdata.getVar('PACKAGE_ARCH')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050076
77 if localdata.getVar('IPK_HIERARCHICAL_FEED', False) == "1":
78 # Spread packages across subdirectories so each isn't too crowded
79 if pkgname.startswith('lib'):
80 pkg_prefix = 'lib' + pkgname[3]
81 else:
82 pkg_prefix = pkgname[0]
83
84 # Keep -dbg, -dev, -doc, -staticdev, -locale and -locale-* packages
85 # together. These package suffixes are taken from the definitions of
86 # PACKAGES and PACKAGES_DYNAMIC in meta/conf/bitbake.conf
87 if pkgname[-4:] in ('-dbg', '-dev', '-doc'):
88 pkg_subdir = pkgname[:-4]
89 elif pkgname.endswith('-staticdev'):
90 pkg_subdir = pkgname[:-10]
91 elif pkgname.endswith('-locale'):
92 pkg_subdir = pkgname[:-7]
93 elif '-locale-' in pkgname:
94 pkg_subdir = pkgname[:pkgname.find('-locale-')]
95 else:
96 pkg_subdir = pkgname
97
98 pkgoutdir = "%s/%s/%s/%s" % (outdir, arch, pkg_prefix, pkg_subdir)
99 else:
100 pkgoutdir = "%s/%s" % (outdir, arch)
101
102 bb.utils.mkdirhier(pkgoutdir)
103 os.chdir(root)
104 cleanupcontrol(root)
Andrew Geissler82c905d2020-04-13 13:39:40 -0500105 g = glob.glob('*')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500106 if not g and localdata.getVar('ALLOW_EMPTY', False) != "1":
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500107 bb.note("Not creating empty archive for %s-%s-%s" % (pkg, localdata.getVar('PKGV'), localdata.getVar('PKGR')))
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500108 return
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500109
110 controldir = os.path.join(root, 'CONTROL')
111 bb.utils.mkdirhier(controldir)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500112 ctrlfile = open(os.path.join(controldir, 'control'), 'w')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500113
114 fields = []
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500115 pe = d.getVar('PKGE')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500116 if pe and int(pe) > 0:
117 fields.append(["Version: %s:%s-%s\n", ['PKGE', 'PKGV', 'PKGR']])
118 else:
119 fields.append(["Version: %s-%s\n", ['PKGV', 'PKGR']])
120 fields.append(["Description: %s\n", ['DESCRIPTION']])
121 fields.append(["Section: %s\n", ['SECTION']])
122 fields.append(["Priority: %s\n", ['PRIORITY']])
123 fields.append(["Maintainer: %s\n", ['MAINTAINER']])
124 fields.append(["License: %s\n", ['LICENSE']])
125 fields.append(["Architecture: %s\n", ['PACKAGE_ARCH']])
126 fields.append(["OE: %s\n", ['PN']])
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500127 if d.getVar('HOMEPAGE'):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500128 fields.append(["Homepage: %s\n", ['HOMEPAGE']])
129
130 def pullData(l, d):
131 l2 = []
132 for i in l:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500133 l2.append(d.getVar(i))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500134 return l2
135
136 ctrlfile.write("Package: %s\n" % pkgname)
137 # check for required fields
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500138 for (c, fs) in fields:
139 for f in fs:
140 if localdata.getVar(f, False) is None:
141 raise KeyError(f)
142 # Special behavior for description...
143 if 'DESCRIPTION' in fs:
144 summary = localdata.getVar('SUMMARY') or localdata.getVar('DESCRIPTION') or "."
145 ctrlfile.write('Description: %s\n' % summary)
146 description = localdata.getVar('DESCRIPTION') or "."
147 description = textwrap.dedent(description).strip()
148 if '\\n' in description:
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500149 # Manually indent: multiline description includes a leading space
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500150 for t in description.split('\\n'):
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500151 ctrlfile.write(' %s\n' % (t.strip() or ' .'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500152 else:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500153 # Auto indent
154 ctrlfile.write('%s\n' % textwrap.fill(description, width=74, initial_indent=' ', subsequent_indent=' '))
155 else:
156 ctrlfile.write(c % tuple(pullData(fs, localdata)))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500157
158 custom_fields_chunk = get_package_additional_metadata("ipk", localdata)
159 if custom_fields_chunk is not None:
160 ctrlfile.write(custom_fields_chunk)
161 ctrlfile.write("\n")
162
163 mapping_rename_hook(localdata)
164
165 def debian_cmp_remap(var):
166 # In debian '>' and '<' do not mean what it appears they mean
167 # '<' = less or equal
168 # '>' = greater or equal
169 # adjust these to the '<<' and '>>' equivalents
170 #
171 for dep in var:
172 for i, v in enumerate(var[dep]):
173 if (v or "").startswith("< "):
174 var[dep][i] = var[dep][i].replace("< ", "<< ")
175 elif (v or "").startswith("> "):
176 var[dep][i] = var[dep][i].replace("> ", ">> ")
177
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500178 rdepends = bb.utils.explode_dep_versions2(localdata.getVar("RDEPENDS") or "")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500179 debian_cmp_remap(rdepends)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500180 rrecommends = bb.utils.explode_dep_versions2(localdata.getVar("RRECOMMENDS") or "")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500181 debian_cmp_remap(rrecommends)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500182 rsuggests = bb.utils.explode_dep_versions2(localdata.getVar("RSUGGESTS") or "")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500183 debian_cmp_remap(rsuggests)
184 # Deliberately drop version information here, not wanted/supported by ipk
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500185 rprovides = dict.fromkeys(bb.utils.explode_dep_versions2(localdata.getVar("RPROVIDES") or ""), [])
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600186 rprovides = collections.OrderedDict(sorted(rprovides.items(), key=lambda x: x[0]))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500187 debian_cmp_remap(rprovides)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500188 rreplaces = bb.utils.explode_dep_versions2(localdata.getVar("RREPLACES") or "")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500189 debian_cmp_remap(rreplaces)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500190 rconflicts = bb.utils.explode_dep_versions2(localdata.getVar("RCONFLICTS") or "")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500191 debian_cmp_remap(rconflicts)
192
193 if rdepends:
194 ctrlfile.write("Depends: %s\n" % bb.utils.join_deps(rdepends))
195 if rsuggests:
196 ctrlfile.write("Suggests: %s\n" % bb.utils.join_deps(rsuggests))
197 if rrecommends:
198 ctrlfile.write("Recommends: %s\n" % bb.utils.join_deps(rrecommends))
199 if rprovides:
200 ctrlfile.write("Provides: %s\n" % bb.utils.join_deps(rprovides))
201 if rreplaces:
202 ctrlfile.write("Replaces: %s\n" % bb.utils.join_deps(rreplaces))
203 if rconflicts:
204 ctrlfile.write("Conflicts: %s\n" % bb.utils.join_deps(rconflicts))
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500205 ctrlfile.write("Source: %s\n" % recipesource)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500206 ctrlfile.close()
207
208 for script in ["preinst", "postinst", "prerm", "postrm"]:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500209 scriptvar = localdata.getVar('pkg_%s' % script)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500210 if not scriptvar:
211 continue
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500212 scriptfile = open(os.path.join(controldir, script), 'w')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500213 scriptfile.write(scriptvar)
214 scriptfile.close()
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600215 os.chmod(os.path.join(controldir, script), 0o755)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500216
217 conffiles_str = ' '.join(get_conffiles(pkg, d))
218 if conffiles_str:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500219 conffiles = open(os.path.join(controldir, 'conffiles'), 'w')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500220 for f in conffiles_str.split():
221 if os.path.exists(oe.path.join(root, f)):
222 conffiles.write('%s\n' % f)
223 conffiles.close()
224
225 os.chdir(basedir)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500226 subprocess.check_output("PATH=\"%s\" %s %s %s" % (localdata.getVar("PATH"),
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500227 d.getVar("OPKGBUILDCMD"), pkg, pkgoutdir),
228 stderr=subprocess.STDOUT,
229 shell=True)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500230
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500231 if d.getVar('IPK_SIGN_PACKAGES') == '1':
232 ipkver = "%s-%s" % (d.getVar('PKGV'), d.getVar('PKGR'))
233 ipk_to_sign = "%s/%s_%s_%s.ipk" % (pkgoutdir, pkgname, ipkver, d.getVar('PACKAGE_ARCH'))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500234 sign_ipk(d, ipk_to_sign)
235
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500236 finally:
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500237 cleanupcontrol(root)
238 bb.utils.unlockfile(lf)
239
Andrew Geissler82c905d2020-04-13 13:39:40 -0500240# Have to list any variables referenced as X_<pkg> that aren't in pkgdata here
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500241IPKEXTRAVARS = "PRIORITY MAINTAINER PACKAGE_ARCH HOMEPAGE PACKAGE_ADD_METADATA_IPK"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500242ipk_write_pkg[vardeps] += "${@gen_packagevar(d, 'IPKEXTRAVARS')}"
243
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500244# Otherwise allarch packages may change depending on override configuration
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500245ipk_write_pkg[vardepsexclude] = "OVERRIDES"
246
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500247
248SSTATETASKS += "do_package_write_ipk"
249do_package_write_ipk[sstate-inputdirs] = "${PKGWRITEDIRIPK}"
250do_package_write_ipk[sstate-outputdirs] = "${DEPLOY_DIR_IPK}"
251
252python do_package_write_ipk_setscene () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500253 tmpdir = d.getVar('TMPDIR')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500254
255 if os.access(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"), os.R_OK):
256 os.unlink(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"))
257
258 sstate_setscene(d)
259}
260addtask do_package_write_ipk_setscene
261
262python () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500263 if d.getVar('PACKAGES') != '':
Brad Bishop316dfdd2018-06-25 12:45:53 -0400264 deps = ' opkg-utils-native:do_populate_sysroot virtual/fakeroot-native:do_populate_sysroot xz-native:do_populate_sysroot'
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500265 d.appendVarFlag('do_package_write_ipk', 'depends', deps)
266 d.setVarFlag('do_package_write_ipk', 'fakeroot', "1")
267}
268
269python do_package_write_ipk () {
270 bb.build.exec_func("read_subpackage_metadata", d)
271 bb.build.exec_func("do_package_ipk", d)
272}
273do_package_write_ipk[dirs] = "${PKGWRITEDIRIPK}"
274do_package_write_ipk[cleandirs] = "${PKGWRITEDIRIPK}"
275do_package_write_ipk[umask] = "022"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500276do_package_write_ipk[depends] += "${@oe.utils.build_depends_string(d.getVar('PACKAGE_WRITE_DEPS'), 'do_populate_sysroot')}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500277addtask package_write_ipk after do_packagedata do_package
278
279PACKAGEINDEXDEPS += "opkg-utils-native:do_populate_sysroot"
280PACKAGEINDEXDEPS += "opkg-native:do_populate_sysroot"
281
282do_build[recrdeptask] += "do_package_write_ipk"