Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 1 | require libva.inc |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 2 | |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 3 | PACKAGECONFIG ??= " \ |
| 4 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', '', d)} \ |
| 5 | ${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} \ |
| 6 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 8 | PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxext libxfixes" |
| 9 | PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/mesa" |
| 10 | |
| 11 | PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
| 13 | PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland" |
| 14 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 15 | RDEPENDS:${PN}-x11 =+ "${PN}" |
| 16 | RDEPENDS:${PN}-glx =+ "${PN}-x11" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 18 | FILES:${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}" |
| 19 | FILES:${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}" |
| 20 | FILES:${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}" |